aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ruby
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-03-18 15:54:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-03-18 15:54:34 +0000
commitf316605d6596d4002a2389b8b2dabd2571207415 (patch)
treec4188311d7ed75d14696365f5b1f2f4e40b4258a /www/mod_ruby
parent057187dfc8d6084d42e82a4328d6aafd478c0300 (diff)
downloadports-f316605d6596d4002a2389b8b2dabd2571207415.tar.gz
ports-f316605d6596d4002a2389b8b2dabd2571207415.zip
Notes
Diffstat (limited to 'www/mod_ruby')
-rw-r--r--www/mod_ruby/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 74b9672a4e37..121c069cfb9a 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= eruby.10:${PORTSDIR}/textproc/eruby
USE_APACHE= yes
USE_RUBY= yes
-USE_REINPLACE= yes
CONFIGURE_ARGS= --with-apxs="${APXS}" \
--enable-eruby=yes \
@@ -35,6 +34,11 @@ DOCS_JA= README.ja doc/default.css doc/*.ja.*
.include <bsd.port.pre.mk>
+AP_CUR_VERSION!= ${ECHO_CMD} ${APACHE_PORT} | ${SED} -ne 's,.*/apache\([0-9]*\).*,\1,p'
+.if ${AP_CUR_VERSION} > 20
+CONFIGURE_ARGS+= --with-apr-includes="`${LOCALBASE}/bin/apr-1-config --includedir`"
+.endif
+
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} ${RUBY_FLAGS} configure.rb ${CONFIGURE_ARGS}
.if !defined(WITHOUT_PTHREADS)