aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ruby
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-01-24 14:40:42 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-01-24 14:40:42 +0000
commit858ea90f3845504b420b0d4f09ce1bff2e0ce543 (patch)
treeaaa955cd8f906df765a1f4f32df59ef7ac79b6c8 /www/mod_ruby
parent41de8b251a212d9462b492f3b2b62823edc0ac34 (diff)
- new option WITHOUT_PTHREADS
Notes
Notes: svn path=/head/; revision=154354
Diffstat (limited to 'www/mod_ruby')
-rw-r--r--www/mod_ruby/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index e23e35ed0086..8aec30963264 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -37,11 +37,15 @@ DOCS_JA= README.ja doc/default.css doc/*.ja.*
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} ${RUBY_FLAGS} configure.rb ${CONFIGURE_ARGS}
+.if !defined(WITHOUT_PTHREADS)
# dirty hack to force mod_ruby.so linked with lpthread.so, otherwise unresolved
# symbols happen
.if ${OSVERSION} >= 502102
@${REINPLACE_CMD} -e 's|-pthread|-pthread -lpthread|' ${WRKSRC}/Makefile
.endif
+.else
+PKGNAMESUFFIX= -nopthreads
+.endif
post-install: doc-install
${INSTALL_DATA} ${WRKSRC}/examples/httpd.conf `${APXS} -q SYSCONFDIR`/httpd.conf.${PORTNAME}