aboutsummaryrefslogtreecommitdiff
path: root/www/mod_scgi
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-23 18:54:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-23 18:54:36 +0000
commitfdaabe56018bab7dc71eb5c4d6afbac8352df77e (patch)
tree13ca897e46db5c077ed3b08ec8aa077fadf81ae1 /www/mod_scgi
parentbcd9bf454e8af51513c8636c0c1d8df5b92d9dcf (diff)
downloadports-fdaabe56018bab7dc71eb5c4d6afbac8352df77e.tar.gz
ports-fdaabe56018bab7dc71eb5c4d6afbac8352df77e.zip
Notes
Diffstat (limited to 'www/mod_scgi')
-rw-r--r--www/mod_scgi/Makefile16
-rw-r--r--www/mod_scgi/pkg-plist3
2 files changed, 7 insertions, 12 deletions
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 111b75deaf7f..b75f1547124b 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= scgi
+PORTNAME= mod_scgi
PORTVERSION= 1.12
CATEGORIES= www
MASTER_SITES= http://quixote.python.ca/releases/ \
@@ -16,11 +16,15 @@ DISTNAME= scgi-${PORTVERSION:S/.a/a/}
MAINTAINER= dryice@dryice.name
COMMENT= Apache module that implements the client side of the SCGI protocol
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
-USE_APACHE= 1.3+
WRKSRC= ${WRKDIR}/${DISTNAME}/${SCGI_DIR}
+USE_APACHE= 1.3+
+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
.include <bsd.port.pre.mk>
.if ${APACHE_VERSION} >= 20
@@ -28,12 +32,6 @@ SCGI_DIR= apache2
.else
SCGI_DIR= apache1
.endif
-PLIST_SUB= APACHE_DIR=${APACHEMODDIR}
-
-do-build:
- cd ${WRKSRC} && ${APXS} -c mod_scgi.c
-do-install:
- cd ${WRKSRC} && ${APXS} -i -c mod_scgi.c
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_scgi/pkg-plist b/www/mod_scgi/pkg-plist
deleted file mode 100644
index 26da03d3d307..000000000000
--- a/www/mod_scgi/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%APACHE_DIR%%/mod_scgi.so
-@exec %D/sbin/apxs -e -a -n scgi %f
-@unexec %D/sbin/apxs -e -A -n scgi %f