aboutsummaryrefslogtreecommitdiff
path: root/www/mod_scgi
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-10-12 12:54:42 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-10-12 12:54:42 +0000
commitc12ca0989b88593375f57236909767c9585c23d9 (patch)
tree2d8c95b932b552f413c86b4593ab37bd914f8bc9 /www/mod_scgi
parent34a0c912635200aa37fbe5916df938026fc9366b (diff)
Notes
Diffstat (limited to 'www/mod_scgi')
-rw-r--r--www/mod_scgi/Makefile22
-rw-r--r--www/mod_scgi/distinfo4
-rw-r--r--www/mod_scgi/files/apache24-compat-mod__scgi.c49
-rw-r--r--www/mod_scgi/pkg-descr2
-rw-r--r--www/mod_scgi/pkg-message2
5 files changed, 68 insertions, 11 deletions
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 3e20bd2a558f..e8fa3d892e3d 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -2,20 +2,28 @@
# $FreeBSD$
PORTNAME= mod_scgi
-PORTVERSION= 1.12
-PORTREVISION= 2
+PORTVERSION= 1.14
CATEGORIES= www
-MASTER_SITES= http://dryice.name/computer/FreeBSD/distfiles/
+MASTER_SITES= http://python.ca/scgi/releases/
DISTNAME= scgi-${PORTVERSION:S/.a/a/}
-MAINTAINER= dryice@dryice.name
-COMMENT= Apache 2.2 module that implements the client side of the SCGI protocol
+MAINTAINER= w.schwarzenfeld@aon.at
+COMMENT= Apache module that implements the client side of the SCGI protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE.txt
SCGI_DIR= apache2
WRKSRC= ${WRKDIR}/${DISTNAME}/${SCGI_DIR}
-USE_APACHE= 22
+USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} == 24
+EXTRA_PATCHES= ${FILESDIR}/apache24-compat-mod__scgi.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_scgi/distinfo b/www/mod_scgi/distinfo
index c9ddd741e988..bc296fd6ab19 100644
--- a/www/mod_scgi/distinfo
+++ b/www/mod_scgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scgi-1.12.tar.gz) = aac7904154c0cdc1b987365a6b9b84719e36af07a7044d6ced12aa5bb099b754
-SIZE (scgi-1.12.tar.gz) = 28132
+SHA256 (scgi-1.14.tar.gz) = 0cde41e4ae58ea666f17f6b1984e8ed8ebaff92cabac4b1b36f86bc47eb18e75
+SIZE (scgi-1.14.tar.gz) = 29406
diff --git a/www/mod_scgi/files/apache24-compat-mod__scgi.c b/www/mod_scgi/files/apache24-compat-mod__scgi.c
new file mode 100644
index 000000000000..21b1cfefa91f
--- /dev/null
+++ b/www/mod_scgi/files/apache24-compat-mod__scgi.c
@@ -0,0 +1,49 @@
+--- mod_scgi.c.orig 2009-11-21 23:02:06 UTC
++++ mod_scgi.c
+@@ -135,16 +135,16 @@ static int scgi_map_location(request_rec
+ return DECLINED;
+ }
+
+-static void log_err(const char *file, int line, request_rec *r,
++static void log_err(const char *file, int line, int index, request_rec *r,
+ apr_status_t status, const char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
++ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
+ }
+
+-static void log_debug(const char *file, int line, request_rec *r, const
++static void log_debug(const char *file, int line, int index, request_rec *r, const
+ char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
++ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
+ }
+
+ static char *http2env(apr_pool_t *p, const char *name)
+@@ -312,7 +312,7 @@ send_headers(request_rec *r, struct sock
+ int i;
+ apr_status_t rv = 0;
+ apr_port_t port = 0;
+- GET_PORT(port, r->connection->remote_addr);
++ GET_PORT(port, r->useragent_addr);
+
+ log_debug(APLOG_MARK,r, "sending headers");
+ t = apr_table_make(r->pool, 40);
+@@ -324,14 +324,14 @@ send_headers(request_rec *r, struct sock
+ buf = "0";
+ add_header(t, "CONTENT_LENGTH", buf);
+ add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
+- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
++ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
+ add_header(t, "SERVER_PROTOCOL", r->protocol);
+ add_header(t, "SERVER_NAME", ap_get_server_name(r));
+ add_header(t, "SERVER_ADMIN", r->server->server_admin);
+ add_header(t, "SERVER_ADDR", r->connection->local_ip);
+ add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
+ ap_get_server_port(r)));
+- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
++ add_header(t, "REMOTE_ADDR", r->useragent_ip);
+ add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
+ add_header(t, "REMOTE_USER", r->user);
+ add_header(t, "REQUEST_METHOD", r->method);
diff --git a/www/mod_scgi/pkg-descr b/www/mod_scgi/pkg-descr
index 63cae96e93fc..25acb887a54b 100644
--- a/www/mod_scgi/pkg-descr
+++ b/www/mod_scgi/pkg-descr
@@ -6,4 +6,4 @@ The SCGI protocol is a replacement for the Common Gateway Interface
HTTP servers. It is similar to FastCGI but is designed to be easier to
implement.
-WWW: http://www.mems-exchange.org/software/scgi/
+WWW: http://python.ca/scgi/
diff --git a/www/mod_scgi/pkg-message b/www/mod_scgi/pkg-message
index 6f5ae41bdc64..7814ebd9b474 100644
--- a/www/mod_scgi/pkg-message
+++ b/www/mod_scgi/pkg-message
@@ -1,3 +1,3 @@
********************************************************************
-* If your mod_scgi seg fault, try disable mod_fastcgi *
+* If your mod_scgi seg faults, try disabling mod_fastcgi *
********************************************************************