aboutsummaryrefslogtreecommitdiff
path: root/www/mod_security
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-12-10 14:25:43 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-12-10 14:25:43 +0000
commitcd2ef5080ae2e6114c7d4c6a3abe9827b019570f (patch)
tree3f88552e12e78bcedb33c89b218d9b448da33943 /www/mod_security
parent885e61e9e5e2bccde56a78eb4f564b6fec136c68 (diff)
downloadports-cd2ef5080ae2e6114c7d4c6a3abe9827b019570f.tar.gz
ports-cd2ef5080ae2e6114c7d4c6a3abe9827b019570f.zip
Notes
Diffstat (limited to 'www/mod_security')
-rw-r--r--www/mod_security/Makefile23
-rw-r--r--www/mod_security/distinfo5
-rw-r--r--www/mod_security/pkg-plist8
3 files changed, 12 insertions, 24 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 5848dd7cc960..086089a08c4c 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -6,39 +6,32 @@
#
PORTNAME= mod_security
-PORTVERSION= 1.8.7
+PORTVERSION= 1.9.1
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/download/
-DISTNAME= ${PORTNAME:S/_//}-${PORTVERSION}
+DISTNAME= ${PORTNAME:S/_//}-apache-${PORTVERSION}
MAINTAINER= ale@FreeBSD.org
COMMENT= An intrusion detection and prevention engine
-USE_APACHE= yes
+USE_APACHE= 1.3+
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/apache2/httpd.h)
-WITH_APACHE2= yes
-.endif
-
-.if defined(WITH_APACHE2)
+.if ${APACHE_VERSION} > 13
APWRKSRC?= ${WRKSRC}/apache2
-PLIST_SUB= APACHE=apache2
-SO= la
.else
APWRKSRC?= ${WRKSRC}/apache1
-PLIST_SUB= APACHE=apache
-SO= so
.endif
-DOCS= CHANGES INSTALL LICENSE README modsecurity-manual.pdf
+DOCS= CHANGES INSTALL LICENSE README doc/modsecurity-apache-manual-1.9.pdf
+PORTDOCS= *
do-build:
- @cd ${APWRKSRC} && ${APXS} -c mod_security.c
+ @cd ${APWRKSRC} && ${APXS} -c ${MODULENAME}.c
do-install:
- ${APXS} -i -a -n security ${APWRKSRC}/mod_security.${SO}
+ ${APXS} -i -a -n ${SHORTMODNAME} ${APWRKSRC}/${MODULENAME}.${AP_BUILDEXT}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/httpd.conf.example-* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
diff --git a/www/mod_security/distinfo b/www/mod_security/distinfo
index 1208afb49ada..84d5bb7f56b4 100644
--- a/www/mod_security/distinfo
+++ b/www/mod_security/distinfo
@@ -1,2 +1,3 @@
-MD5 (modsecurity-1.8.7.tar.gz) = 0dd48656e451c711358c097dc80e0369
-SIZE (modsecurity-1.8.7.tar.gz) = 313004
+MD5 (modsecurity-apache-1.9.1.tar.gz) = d648ba26b1dba708a06344072bea984c
+SHA256 (modsecurity-apache-1.9.1.tar.gz) = b8ef27d4bdfa652884217592c1c17d31a78a1b97978a9d9e2b7dcdf6e969cd6b
+SIZE (modsecurity-apache-1.9.1.tar.gz) = 395659
diff --git a/www/mod_security/pkg-plist b/www/mod_security/pkg-plist
index c0bd7e7cb218..ee7534043358 100644
--- a/www/mod_security/pkg-plist
+++ b/www/mod_security/pkg-plist
@@ -1,11 +1,5 @@
-libexec/%%APACHE%%/mod_security.so
+%%APACHEMODDIR%%/%%AP_MODULE%%
@exec %D/sbin/apxs -e -a -n security %D/%F
@unexec %D/sbin/apxs -e -A -n security %D/%F
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/modsecurity-manual.pdf
%%EXAMPLESDIR%%/httpd.conf.example-minimal
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%