aboutsummaryrefslogtreecommitdiff
path: root/www/mod_security
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-07-20 17:59:44 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-07-20 17:59:44 +0000
commit6752d836175871a566bb46910d42b54af1b20cd2 (patch)
tree97f0b95d7459d81611fe2b3836300cf4e05d811e /www/mod_security
parent02825d960949df6dfedd60d448974cc2934c6466 (diff)
downloadports-6752d836175871a566bb46910d42b54af1b20cd2.tar.gz
ports-6752d836175871a566bb46910d42b54af1b20cd2.zip
Notes
Diffstat (limited to 'www/mod_security')
-rw-r--r--www/mod_security/Makefile14
-rw-r--r--www/mod_security/files/patch-configure11
2 files changed, 24 insertions, 1 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index cb918d465d62..5f84b253efea 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_security
PORTVERSION= 2.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/download/
DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
@@ -35,6 +35,7 @@ DOCSDIR= ${PREFIX}/share/doc/${MODULENAME}
SUB_FILES+= mod_security2.conf
SUB_LIST+= APACHEETCDIR="${APACHEETCDIR}"
PLIST_FILES+= ${APACHEMODDIR}/mod_security2.so
+OPTIONS= LUA "Embedded Lua language support (EXPERIMENTAL)" off
.if !defined(SKIP_RULES)
SUB_FILES+= pkg-message.rules
@@ -64,6 +65,14 @@ PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules/modsecurity_
.endif
+.if defined(WITH_LUA)
+USE_LUA= 5.1+
+CONFIGURE_ARGS+= --with-lua=${LOCALBASE}
+LIB_DEPENDS+= lua.1:${PORTSDIR}/lang/lua
+.else
+CONFIGURE_ARGS+= --without-lua
+.endif
+
REINPLACE_ARGS= -i ""
post-patch:
@@ -73,6 +82,9 @@ post-patch:
s|SecDebugLog.*logs/modsec_debug.log|SecDebugLog /var/log/httpd-modsec2_debug.log|; \
s|SecServerSignature "Apache/2.2.0 (Fedora)"|SecServerSignature "Apache/${APACHE_VERSION:C/[0-9]/\0./g}x (${OPSYS})"|; \
' ${WRKSRCTOP}/rules/modsecurity_crs_10_config.conf
+.if defined(WITH_LUA)
+ ${REINPLACE_CMD} -e 's|%%LUA_VER%%|${LUA_VER}|' ${WRKSRC}/configure
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/mod_security/files/patch-configure b/www/mod_security/files/patch-configure
new file mode 100644
index 000000000000..017188e6fdda
--- /dev/null
+++ b/www/mod_security/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-06-04 09:32:50.000000000 +0900
++++ configure 2008-06-04 09:35:07.000000000 +0900
+@@ -5132,7 +5132,7 @@
+
+
+ LUA_CONFIG="pkg-config"
+-LUA_PKGNAMES="lua5.1 lua5 lua"
++LUA_PKGNAMES="lua5.1 lua5 lua lua-%%LUA_VER%% "
+ LUA_CFLAGS=""
+ LUA_LIBS=""
+