aboutsummaryrefslogtreecommitdiff
path: root/www/mod_spdy/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-06 06:12:30 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-06 06:12:30 +0000
commit9bcbee8d572eaf58dc49b36e830dbae7ade384bc (patch)
treef24fed9a43e3b968ebd76e486b6bb2654797157e /www/mod_spdy/Makefile
parent2fdbfc0e430f7903a10eb5cb7d76075d38c52ac6 (diff)
downloadports-9bcbee8d572eaf58dc49b36e830dbae7ade384bc.tar.gz
ports-9bcbee8d572eaf58dc49b36e830dbae7ade384bc.zip
Notes
Diffstat (limited to 'www/mod_spdy/Makefile')
-rw-r--r--www/mod_spdy/Makefile31
1 files changed, 12 insertions, 19 deletions
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 00af42b92ea9..f59581977252 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_spdy
PORTVERSION= 0.9.2.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.club.kyutech.ac.jp/~masaki/ports/:mod_spdy \
${MASTER_SITE_APACHE_HTTPD}:apache22 \
@@ -44,41 +45,33 @@ GYP_DEFINES+= \
system_include_path_execinfo=${LOCALBASE}/include \
include_dirs=${LOCALBASE}/include
-OPTIONS= CLANG "Build with Clang" on \
- GCC46 "Build with GCC 4.6+" off \
- DEBUG "Compile with debug symbols and verbose output" off
+OPTIONS_DEFINE= CLANG DEBUG
+CLANG_DESC= Build with Clang instead of GCC 4.6+
+DEBUG_DESC= Compile with debug symbols and verbose output
+
+OPTIONS_DEFAULT= CLANG
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900033 || defined(WITH_GCC46)
+.if ${OSVERSION} < 900033 || ! ${PORT_OPTIONS:MCLANG}
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif
-.if !defined(WITH_GCC46) && !defined(WITH_CLANG)
-IGNORE= does not compile with base gcc
-.endif
-
-.if defined(WITH_GCC46) && defined(WITH_CLANG)
-IGNORE= conflicting options (CLANG and GCC46)
-.endif
-
-.if defined(WITH_GCC46)
-USE_GCC?= 4.6+
-.endif
-
-.if defined(WITH_CLANG)
+.if ${PORT_OPTIONS:MCLANG}
.if ${OSVERSION} < 900033
BUILD_DEPENDS+= clang:${PORTSDIR}/lang/clang
.endif
CC= clang
CXX= clang++
-CPP= clang-cpp
GYP_DEFINES+= clang=1
+.else
+USE_GCC?= 4.6+
+GYP_DEFINES+= gcc_version=${CXX:S/g++//}
.endif
-.if !defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
BUILDTYPE= Release
.else
MAKE_ENV+= V=1