aboutsummaryrefslogtreecommitdiff
path: root/www/mod_sqlinclude/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2004-06-03 12:39:56 +0000
committerAnders Nordby <anders@FreeBSD.org>2004-06-03 12:39:56 +0000
commit072b0fc121907de78e2c66b51442c551614d1d01 (patch)
treea6cc1409d07696f5c58f5081ed72aee30d801ef9 /www/mod_sqlinclude/Makefile
parent72b1f5a129d46996df886967c2f198c486a0f7e1 (diff)
downloadports-072b0fc121907de78e2c66b51442c551614d1d01.tar.gz
ports-072b0fc121907de78e2c66b51442c551614d1d01.zip
Notes
Diffstat (limited to 'www/mod_sqlinclude/Makefile')
-rw-r--r--www/mod_sqlinclude/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
index 6aa242a7051a..aa53b148755c 100644
--- a/www/mod_sqlinclude/Makefile
+++ b/www/mod_sqlinclude/Makefile
@@ -5,20 +5,25 @@
# $FreeBSD$
PORTNAME= mod_sqlinclude
-PORTVERSION= 1.2
+PORTVERSION= 1.4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module implementing config inclusion from MySQL databases
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= yes
+DOCS= CHANGES.txt README.txt test.sql
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_APACHE2) || exists(${LOCALBASE}/include/apache2/apr.h)
+IGNORE= Sorry, mod_sqlinclude only works with Apache 1.x
+.else
USE_APACHE= yes
-DOCS= CHANGES.txt README.txt TODO.txt
+.endif
do-build:
(cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
@@ -33,4 +38,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>