aboutsummaryrefslogtreecommitdiff
path: root/www/mod_sqlinclude/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2001-11-12 02:09:15 +0000
committerAnders Nordby <anders@FreeBSD.org>2001-11-12 02:09:15 +0000
commit4417a778f41170679f5eabb971094cd5c89b7c76 (patch)
treec4c4e9b17b0e623bab337e7fbe60fb5360587590 /www/mod_sqlinclude/Makefile
parente4d88f396affc7dbeecd407c50fb3d113829b849 (diff)
downloadports-4417a778f41170679f5eabb971094cd5c89b7c76.tar.gz
ports-4417a778f41170679f5eabb971094cd5c89b7c76.zip
Notes
Diffstat (limited to 'www/mod_sqlinclude/Makefile')
-rw-r--r--www/mod_sqlinclude/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
new file mode 100644
index 000000000000..0c388212eed7
--- /dev/null
+++ b/www/mod_sqlinclude/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_sqlinclude
+# Date created: October 25 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+
+PORTNAME= mod_sqlinclude
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://wfmh.org.pl/~carlos/files/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+DOCS= CHANGES.txt README.txt TODO.txt
+
+do-build:
+ (cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient mod_sqlinclude.c)
+
+do-install:
+ (cd ${WRKSRC} && ${APXS} -i -A -n 'sqlinclude' mod_sqlinclude.so)
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>