aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ticket
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 22:52:14 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 22:52:14 +0000
commit1e9d64f0b5e4835b504838e6711c7989cba71435 (patch)
tree983d6496d36dacac00019ad702b791c3368255b9 /www/mod_ticket
parent6f8fbc6735725c311a366de1469b64db7078367d (diff)
downloadports-1e9d64f0b5e4835b504838e6711c7989cba71435.tar.gz
ports-1e9d64f0b5e4835b504838e6711c7989cba71435.zip
Notes
Diffstat (limited to 'www/mod_ticket')
-rw-r--r--www/mod_ticket/Makefile32
-rw-r--r--www/mod_ticket/distinfo1
-rw-r--r--www/mod_ticket/pkg-comment1
-rw-r--r--www/mod_ticket/pkg-descr7
-rw-r--r--www/mod_ticket/pkg-plist3
5 files changed, 44 insertions, 0 deletions
diff --git a/www/mod_ticket/Makefile b/www/mod_ticket/Makefile
new file mode 100644
index 000000000000..dfe5e5d37a8c
--- /dev/null
+++ b/www/mod_ticket/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mod_ticket
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_ticket
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://germ.semiotek.com/ticket/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_ticket/distinfo b/www/mod_ticket/distinfo
new file mode 100644
index 000000000000..5e1f4418726f
--- /dev/null
+++ b/www/mod_ticket/distinfo
@@ -0,0 +1 @@
+MD5 (mod_ticket.c) = 3d05d91b1d49faa4b9689a3213b0d458
diff --git a/www/mod_ticket/pkg-comment b/www/mod_ticket/pkg-comment
new file mode 100644
index 000000000000..d2b109b32e0b
--- /dev/null
+++ b/www/mod_ticket/pkg-comment
@@ -0,0 +1 @@
+Apache module for a digitally signed ticket in URL
diff --git a/www/mod_ticket/pkg-descr b/www/mod_ticket/pkg-descr
new file mode 100644
index 000000000000..c124a338ce0b
--- /dev/null
+++ b/www/mod_ticket/pkg-descr
@@ -0,0 +1,7 @@
+Apache module mod_ticket scans a URI for a digitally signed ticket
+and, if the md5 signature is valid, makes it available as $TICKET
+in the environment of sub-processes. The signature is generated
+from a shared secret combined with the ticket value and the IP of
+the remote user.
+
+WWW: http://germ.semiotek.com/ticket/
diff --git a/www/mod_ticket/pkg-plist b/www/mod_ticket/pkg-plist
new file mode 100644
index 000000000000..33a8d7f8577d
--- /dev/null
+++ b/www/mod_ticket/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_ticket.so
+@exec %D/sbin/apxs -e -A -n ticket %D/%F
+@unexec %D/sbin/apxs -e -A -n ticket %D/%F