aboutsummaryrefslogtreecommitdiff
path: root/www/mod_tidy/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-10-15 19:48:03 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-10-15 19:48:03 +0000
commit60575e0bb90f66f96677b4e71677e60470f5cf4b (patch)
treeb396fa10ce07fc544d87f5846066804d673a5939 /www/mod_tidy/Makefile
parent83037c0e8c0e7d076131e0e34d6cd460bcec33a7 (diff)
downloadports-60575e0bb90f66f96677b4e71677e60470f5cf4b.tar.gz
ports-60575e0bb90f66f96677b4e71677e60470f5cf4b.zip
Notes
Diffstat (limited to 'www/mod_tidy/Makefile')
-rw-r--r--www/mod_tidy/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/www/mod_tidy/Makefile b/www/mod_tidy/Makefile
new file mode 100644
index 000000000000..eacbfd09431e
--- /dev/null
+++ b/www/mod_tidy/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mod_tidy
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_tidy
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://home.snafu.de/tusk/mod_tidy/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Validates the HTML output of your apache2 webserver
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= tidy:${PORTSDIR}/www/tidy-lib
+
+RESTRICTED= "no license"
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+TIDY_INC= ${LOCALBASE}/include/tidy
+TIDY_LIBS= ${LOCALBASE}/lib
+
+post-extract:
+ @${ECHO_MSG} "===> Removing distributed tidy libs to avoid conflicts"
+ @${RM} -fr ${WRKSRC}/tidy
+
+do-build:
+ @(cd ${WRKSRC}/src && ${APXS} -I ${TIDY_INC} -L ${TIDY_LIBS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/src && ${APXS} -A -i ${PORTNAME}.la)
+
+.include <bsd.port.mk>