aboutsummaryrefslogtreecommitdiff
path: root/www/mod_traf_thief/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-10-16 16:59:19 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-10-16 16:59:19 +0000
commit6c910b584456271eece85614eaec922b933242a1 (patch)
treea6473d657dd5ec86ada8c2d3c65d818a91801c23 /www/mod_traf_thief/Makefile
parenteca01a135b49a571e34329bd33554a8c3798fed2 (diff)
downloadports-6c910b584456271eece85614eaec922b933242a1.tar.gz
ports-6c910b584456271eece85614eaec922b933242a1.zip
Notes
Diffstat (limited to 'www/mod_traf_thief/Makefile')
-rw-r--r--www/mod_traf_thief/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/mod_traf_thief/Makefile b/www/mod_traf_thief/Makefile
new file mode 100644
index 000000000000..6a06379e5db2
--- /dev/null
+++ b/www/mod_traf_thief/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_traf_thief
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_traf_thief
+PORTVERSION= 0.01
+CATEGORIES= www
+MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/
+EXTRACT_SUFX= .c
+# Original location: http://web.god.net.ru/projects/mod_traf_thief/dist/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Allows you to redirect part of the traffic to your url
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_WRKSUBDIR= YES
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}.c
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.la)
+
+.include <bsd.port.mk>