aboutsummaryrefslogtreecommitdiff
path: root/www/mod_transform
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-08 21:27:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-08 21:27:24 +0000
commit4747781ba06254d5d284a031c546a9da7a5f64f4 (patch)
tree75fe39dcec18cbbc61f4986cea1bb4ed0f4cb66d /www/mod_transform
parent43f65bc3635792e86f21dba05f0da2a959db210d (diff)
downloadports-4747781ba06254d5d284a031c546a9da7a5f64f4.tar.gz
ports-4747781ba06254d5d284a031c546a9da7a5f64f4.zip
Notes
Diffstat (limited to 'www/mod_transform')
-rw-r--r--www/mod_transform/Makefile25
-rw-r--r--www/mod_transform/distinfo2
-rw-r--r--www/mod_transform/pkg-descr10
-rw-r--r--www/mod_transform/pkg-message8
-rw-r--r--www/mod_transform/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/www/mod_transform/Makefile b/www/mod_transform/Makefile
new file mode 100644
index 000000000000..b902ae71abe5
--- /dev/null
+++ b/www/mod_transform/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mod_transform
+# Date created: 5 December 2004
+# Whom: laruiss
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_transform
+PORTVERSION= 0.6.0
+CATEGORIES= www
+MASTER_SITES= http://www.outoforder.cc/downloads/mod_transform/
+
+MAINTAINER= stan@stormier.net
+COMMENT= An XSLT and XIncludes Filter module for Apache 2.0
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+
+HAS_CONFIGURE= yes
+USE_GNOME= libxslt
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_transform/distinfo b/www/mod_transform/distinfo
new file mode 100644
index 000000000000..40c1a7033980
--- /dev/null
+++ b/www/mod_transform/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_transform-0.6.0.tar.gz) = 8b27adea2536f105470b4bedc418ab3b
+SIZE (mod_transform-0.6.0.tar.gz) = 301889
diff --git a/www/mod_transform/pkg-descr b/www/mod_transform/pkg-descr
new file mode 100644
index 000000000000..93cb4f20b45d
--- /dev/null
+++ b/www/mod_transform/pkg-descr
@@ -0,0 +1,10 @@
+mod_transform is a filter module that allows Apache 2.0 to do dynamic XSL
+Transformations on either static XML documents, or XML documents generated
+from another Apache module or CGI program.
+
+This module originated from mod_xml_gnome_xslt by WebThing.
+
+WWW: http://www.outoforder.cc/projects/apache/mod_transform/
+
+- Stan
+stan@stormier.net
diff --git a/www/mod_transform/pkg-message b/www/mod_transform/pkg-message
new file mode 100644
index 000000000000..c12a8bcdb935
--- /dev/null
+++ b/www/mod_transform/pkg-message
@@ -0,0 +1,8 @@
+***************************************************************
+
+To use mod_transform, add these lines to your httpd.conf:
+
+LoadModule transform_module libexec/apache2/mod_transform.so
+AddOutputFilter XSLT xml
+
+***************************************************************
diff --git a/www/mod_transform/pkg-plist b/www/mod_transform/pkg-plist
new file mode 100644
index 000000000000..fcee231f807c
--- /dev/null
+++ b/www/mod_transform/pkg-plist
@@ -0,0 +1,2 @@
+include/apache2/mod_transform.h
+libexec/apache2/mod_transform.so