aboutsummaryrefslogtreecommitdiff
path: root/www/mod_tsa
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 00:37:30 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 00:37:30 +0000
commitdeae86ccebd9d2afc0c6dbdfaca8af9f604f6cbe (patch)
tree07ecc926ec80afb6f049b293fc151df73d3f9b01 /www/mod_tsa
parent173c53f8e789764e943199957f589952c59f91b0 (diff)
downloadports-deae86ccebd9d2afc0c6dbdfaca8af9f604f6cbe.tar.gz
ports-deae86ccebd9d2afc0c6dbdfaca8af9f604f6cbe.zip
Notes
Diffstat (limited to 'www/mod_tsa')
-rw-r--r--www/mod_tsa/Makefile72
-rw-r--r--www/mod_tsa/distinfo2
-rw-r--r--www/mod_tsa/pkg-descr2
-rw-r--r--www/mod_tsa/pkg-plist8
4 files changed, 84 insertions, 0 deletions
diff --git a/www/mod_tsa/Makefile b/www/mod_tsa/Makefile
new file mode 100644
index 000000000000..7feed3f6c743
--- /dev/null
+++ b/www/mod_tsa/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: mod_tsa
+# Date created: 22 November 2010
+# Whom: ubique
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_tsa
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://am.nesiac.org/static/ \
+ http://ubique.spb.ru/src/
+
+MAINTAINER= ubique@peterhost.ru
+COMMENT= Time stamping authority (RFC 3161) module for apache
+
+OPTIONS= MYSQL "Enable support for MySQL storage" Off \
+ PGSQL "Enable support for PostgreSQL" Off \
+ FIREBIRD "Enable support for Firebird storage" Off \
+ DEBUG "Build with debug" Off \
+ DEBUG_MEMORY "Build with memory debug" Off
+
+MAKE_JOBS_SAFE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-openssl-incdir=${OPENSSLINC} \
+ --with-openssl-libdir=${OPENSSLLIB} \
+ --with-apxs=${APXS}
+MAKE_ARGS+= APXS=${APXS}
+
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT= yes
+USE_APACHE= 20+
+AP_EXTRAS+= -DMOD_TSA_VERSION=\\\"mod_tsa/${PORTVERSION}\\\"
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
+PORTEXAMPLES= *.sql tsa.conf
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --enable-mysql=yes
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --enable-pgsql=yes
+.endif
+
+.if defined(WITH_FIREBIRD)
+USE_FIREBIRD= yes
+CONFIGURE_ARGS+= --enable-firebird=yes
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debug=yes
+.endif
+
+.if defined(WITH_DEBUG_MEMORY)
+CONFIGURE_ARGS+= --with-debug-memory=yes
+.endif
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/*.sql ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/tsa.conf ${EXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_tsa/distinfo b/www/mod_tsa/distinfo
new file mode 100644
index 000000000000..d2bf13db68e9
--- /dev/null
+++ b/www/mod_tsa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_tsa-1.0.tar.gz) = b3f18e6fd59a8096335eae3d41dd8a9784525d6682e68854eaacce6576ea67b7
+SIZE (mod_tsa-1.0.tar.gz) = 107162
diff --git a/www/mod_tsa/pkg-descr b/www/mod_tsa/pkg-descr
new file mode 100644
index 000000000000..6dea76840c69
--- /dev/null
+++ b/www/mod_tsa/pkg-descr
@@ -0,0 +1,2 @@
+Time stamping authority module for apache22.
+WWW: http://opentsa.org/
diff --git a/www/mod_tsa/pkg-plist b/www/mod_tsa/pkg-plist
new file mode 100644
index 000000000000..8143b401d398
--- /dev/null
+++ b/www/mod_tsa/pkg-plist
@@ -0,0 +1,8 @@
+%%APACHEMODDIR%%/%%AP_MODULE%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsa.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/firebird_create.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/firebird_destroy.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_create.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_destroy.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql_create.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql_destroy.sql