aboutsummaryrefslogtreecommitdiff
path: root/www/mod_watch
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2004-06-03 14:15:33 +0000
committerAnders Nordby <anders@FreeBSD.org>2004-06-03 14:15:33 +0000
commit15e52923bfbdf9bbeb92ef0f6d8fdf88280a6f07 (patch)
tree7897a24f28e6363669e32c06620e0069bfe2dd7c /www/mod_watch
parent828b1736be4e46b84732b9bdf133b912ee5cfff3 (diff)
downloadports-15e52923bfbdf9bbeb92ef0f6d8fdf88280a6f07.tar.gz
ports-15e52923bfbdf9bbeb92ef0f6d8fdf88280a6f07.zip
Notes
Diffstat (limited to 'www/mod_watch')
-rw-r--r--www/mod_watch/Makefile11
-rw-r--r--www/mod_watch/distinfo4
-rw-r--r--www/mod_watch/files/patch-mod_watch.c48
-rw-r--r--www/mod_watch/pkg-plist32
4 files changed, 34 insertions, 61 deletions
diff --git a/www/mod_watch/Makefile b/www/mod_watch/Makefile
index f2f9cc2cb53f..6bf6c12e1ea4 100644
--- a/www/mod_watch/Makefile
+++ b/www/mod_watch/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= mod_watch
-PORTVERSION= 3.12
-PORTREVISION= 1
+PORTVERSION= 3.18
CATEGORIES= www
-MASTER_SITES= http://www.snert.com/Software/mod_watch/ \
+MASTER_SITES= http://www.snert.com/Software/download/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
EXTRACT_SUFX= .tgz
@@ -26,6 +25,7 @@ MAKE_ARGS+= APXS="${APXS}"
ALL_TARGET= build-dynamic
+RDOCS= CHANGES.TXT LICENSE.TXT notes-conf.txt notes-support.txt
DOCS= apache2mrtg.html index.shtml mailto.js mod_watch.html style.css
DOCS_HTMLIMAGES= apache-header-476-62.png mrpixel.gif mrtg-bar.png \
sun-logo.jpg wave1.jpg
@@ -40,8 +40,9 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nfields.pl ${PREFIX}/sbin
.if !defined(NOPORTDOCS)
@${INSTALL} -d -m 0755 ${DOCSDIR}/html/Img
- ${INSTALL_DATA} ${WRKSRC}/CHANGES.TXT ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/LICENSE.TXT ${DOCSDIR}/
+.for f in ${RDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/html/
.endfor
diff --git a/www/mod_watch/distinfo b/www/mod_watch/distinfo
index 0d16f1a7c486..f92e5b458ba4 100644
--- a/www/mod_watch/distinfo
+++ b/www/mod_watch/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_watch312.tgz) = ef8e7edf465fdddb0762c264fbff6f83
-SIZE (mod_watch312.tgz) = 80853
+MD5 (mod_watch318.tgz) = 1409df800f24214bed16ca753b9967ff
+SIZE (mod_watch318.tgz) = 94668
diff --git a/www/mod_watch/files/patch-mod_watch.c b/www/mod_watch/files/patch-mod_watch.c
index bdb000dd65fe..1b9edeebab8e 100644
--- a/www/mod_watch/files/patch-mod_watch.c
+++ b/www/mod_watch/files/patch-mod_watch.c
@@ -1,5 +1,5 @@
---- mod_watch.c.orig Thu Mar 14 03:44:07 2002
-+++ mod_watch.c Wed Oct 15 22:37:21 2003
+--- mod_watch.c.orig Wed Nov 27 15:20:42 2002
++++ mod_watch.c Thu Jun 3 13:54:49 2004
@@ -41,6 +41,10 @@
* ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
@@ -11,42 +11,12 @@
#ifndef SPOOLDIR
#define SPOOLDIR "/var/spool/mod_watch/"
#endif
-@@ -1037,22 +1041,22 @@
- if (shLock(shtable) && MutexLock(mutex))
- goto error0;
+@@ -74,7 +78,7 @@
-- ap_rprintf(r, "
--<html>
--<style type='text/css'>
--th {
-- font-family: Verdana, Arial, Helvetica, sans-serif;
-- font-size: 10pt;
-- background-color: #0080D7;
-- color: #ffffff;
--}
--.normal, p, ul, td {
-- font-family: Verdana, Arial, Helvetica, sans-serif;
-- font-size: 10pt;
-- color: #000000;
--}
--</style>
--<body>
-+ ap_rprintf(r, "\n\
-+<html>\n\
-+<style type='text/css'>\n\
-+th {\n\
-+ font-family: Verdana, Arial, Helvetica, sans-serif;\n\
-+ font-size: 10pt;\n\
-+ background-color: #0080D7;\n\
-+ color: #ffffff;\n\
-+}\n\
-+.normal, p, ul, td {\n\
-+ font-family: Verdana, Arial, Helvetica, sans-serif;\n\
-+ font-size: 10pt;\n\
-+ color: #000000;\n\
-+}\n\
-+</style>\n\
-+<body>\n\
- "
- );
+ #define MODULE "mod_watch"
+ #define AUTHOR "achowe@snert.com"
+-#define VERSION "3.17"
++#define VERSION "3.18"
+ #define COPYRIGHT_DATE "2001, 2002"
+ #include "httpd.h"
diff --git a/www/mod_watch/pkg-plist b/www/mod_watch/pkg-plist
index 48364f986331..133d59bd7d83 100644
--- a/www/mod_watch/pkg-plist
+++ b/www/mod_watch/pkg-plist
@@ -4,18 +4,20 @@ sbin/nfields.pl
libexec/apache/mod_watch.so
@exec %D/sbin/apxs -e -A -n watch %D/%F
@unexec %D/sbin/apxs -e -A -n watch %D/%F
-%%PORTDOCS%%share/doc/mod_watch/html/Img/apache-header-476-62.png
-%%PORTDOCS%%share/doc/mod_watch/html/Img/mrpixel.gif
-%%PORTDOCS%%share/doc/mod_watch/html/Img/mrtg-bar.png
-%%PORTDOCS%%share/doc/mod_watch/html/Img/sun-logo.jpg
-%%PORTDOCS%%share/doc/mod_watch/html/Img/wave1.jpg
-%%PORTDOCS%%share/doc/mod_watch/html/apache2mrtg.html
-%%PORTDOCS%%share/doc/mod_watch/html/index.shtml
-%%PORTDOCS%%share/doc/mod_watch/html/mailto.js
-%%PORTDOCS%%share/doc/mod_watch/html/mod_watch.html
-%%PORTDOCS%%share/doc/mod_watch/html/style.css
-%%PORTDOCS%%share/doc/mod_watch/CHANGES.TXT
-%%PORTDOCS%%share/doc/mod_watch/LICENSE.TXT
-%%PORTDOCS%%@dirrm share/doc/mod_watch/html/Img
-%%PORTDOCS%%@dirrm share/doc/mod_watch/html
-%%PORTDOCS%%@dirrm share/doc/mod_watch
+%%PORTDOCS%%%%DOCSDIR%%/html/Img/apache-header-476-62.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Img/mrpixel.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Img/mrtg-bar.png
+%%PORTDOCS%%%%DOCSDIR%%/html/Img/sun-logo.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/Img/wave1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/apache2mrtg.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.shtml
+%%PORTDOCS%%%%DOCSDIR%%/html/mailto.js
+%%PORTDOCS%%%%DOCSDIR%%/html/mod_watch.html
+%%PORTDOCS%%%%DOCSDIR%%/html/style.css
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.TXT
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.TXT
+%%PORTDOCS%%%%DOCSDIR%%/notes-conf.txt
+%%PORTDOCS%%%%DOCSDIR%%/notes-support.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/Img
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%