aboutsummaryrefslogtreecommitdiff
path: root/www/mod_webauth
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2015-10-30 16:29:48 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2015-10-30 16:29:48 +0000
commitdc17977dfb180a551f99b1828dd040cb0e657af5 (patch)
tree1f8fb37d03b2863eadc41da841f5d481166ac20c /www/mod_webauth
parent9974b90dd9f263120a3d63cd525c00a6a4537ffe (diff)
downloadports-dc17977dfb180a551f99b1828dd040cb0e657af5.tar.gz
ports-dc17977dfb180a551f99b1828dd040cb0e657af5.zip
Notes
Diffstat (limited to 'www/mod_webauth')
-rw-r--r--www/mod_webauth/Makefile32
-rw-r--r--www/mod_webauth/distinfo2
-rw-r--r--www/mod_webauth/files/patch-lib_userinfo-json.c11
-rw-r--r--www/mod_webauth/pkg-descr20
-rw-r--r--www/mod_webauth/pkg-plist18
5 files changed, 83 insertions, 0 deletions
diff --git a/www/mod_webauth/Makefile b/www/mod_webauth/Makefile
new file mode 100644
index 000000000000..e1800195f3a2
--- /dev/null
+++ b/www/mod_webauth/Makefile
@@ -0,0 +1,32 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_webauth
+PORTVERSION= 4.7.0
+CATEGORIES= www
+MASTER_SITES= http://webauth.stanford.edu/dist/
+DISTNAME= webauth-${PORTVERSION}
+
+MAINTAINER= apache@FreeBSD.org
+COMMENT= Apache module for authenticating users with Kerberos v5
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+
+USES= libtool pkgconfig
+USE_APACHE= 22+
+USE_OPENLDAP= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ldap-lib=${LOCALBASE}/lib \
+ --with-ldap-include=${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/typedef int sig_atomic_t/d' \
+ ${WRKSRC}/portable/system.h
+
+.include <bsd.port.mk>
diff --git a/www/mod_webauth/distinfo b/www/mod_webauth/distinfo
new file mode 100644
index 000000000000..7f1561315ea9
--- /dev/null
+++ b/www/mod_webauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (webauth-4.7.0.tar.gz) = 0fcc077236da03cecfd71d6702f6336a227d9b25ad93e2cd3715568485c74a7f
+SIZE (webauth-4.7.0.tar.gz) = 1323358
diff --git a/www/mod_webauth/files/patch-lib_userinfo-json.c b/www/mod_webauth/files/patch-lib_userinfo-json.c
new file mode 100644
index 000000000000..b0c216a10548
--- /dev/null
+++ b/www/mod_webauth/files/patch-lib_userinfo-json.c
@@ -0,0 +1,11 @@
+--- lib/userinfo-json.c.orig 2015-10-28 19:05:45 UTC
++++ lib/userinfo-json.c
+@@ -22,6 +22,8 @@
+ #endif
+ #include <time.h>
+
++#include <util/macros.h>
++
+ #include <lib/internal.h>
+ #include <webauth/basic.h>
+ #include <webauth/factors.h>
diff --git a/www/mod_webauth/pkg-descr b/www/mod_webauth/pkg-descr
new file mode 100644
index 000000000000..f6cbd91495fe
--- /dev/null
+++ b/www/mod_webauth/pkg-descr
@@ -0,0 +1,20 @@
+WebAuth is an authentication system for web pages and web applications. The
+first time a user attempts to access a web page protected by WebAuth, they
+will be sent to a central login server (weblogin.stanford.edu at Stanford)
+and prompted to authenticate. Normally, they will be asked for a username
+and password, although other authentication methods are possible. Once the
+user has logged in, the weblogin server will send their encrypted identity
+back to the original web page they were trying to access. Their identity
+will also be stored in a cookie set by the weblogin server and they will
+not need to authenticate again until their credentials expire, even if
+they visit multiple protected web sites.
+
+WebAuth works with any browser that supports cookies, requires no agents
+or other software installed on the client web browser systems, and works
+with an existing Kerberos v5 authentication realm. It can also be used as
+the SSO provider for a Shibboleth IdP and supports SPNEGO authentication
+as well as username/password over TLS/SSL. See the page on WebAuth features
+for more major features and a brief comparison with other web
+authentication systems.
+
+WWW: http://webauth.stanford.edu/
diff --git a/www/mod_webauth/pkg-plist b/www/mod_webauth/pkg-plist
new file mode 100644
index 000000000000..a902c145c7b1
--- /dev/null
+++ b/www/mod_webauth/pkg-plist
@@ -0,0 +1,18 @@
+bin/wa_keyring
+include/%%AP_NAME%%/basic.h
+include/%%AP_NAME%%/defines.h
+include/%%AP_NAME%%/factors.h
+include/%%AP_NAME%%/keys.h
+include/%%AP_NAME%%/krb5.h
+include/%%AP_NAME%%/tokens.h
+include/%%AP_NAME%%/util.h
+include/%%AP_NAME%%/was.h
+include/%%AP_NAME%%/webkdc.h
+lib/lib%%AP_NAME%%.a
+lib/lib%%AP_NAME%%.so
+lib/lib%%AP_NAME%%.so.12
+lib/lib%%AP_NAME%%.so.12.0.0
+libdata/pkgconfig/lib%%AP_NAME%%.pc
+libexec/apache2/modules/%%AP_MODULE%%
+libexec/apache2/modules/mod_%%AP_NAME%%ldap.so
+man/man1/wa_keyring.1.gz