aboutsummaryrefslogtreecommitdiff
path: root/www/mod_webkit/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-10-14 16:17:17 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-10-14 16:17:17 +0000
commit41df56b44330308f1609b063ba2a7444d16eeeb5 (patch)
treedbd871e7d951495f470ace8c525261c0ffa9ef25 /www/mod_webkit/Makefile
parentba29c1532cd0a02947ad49e59bd552c1d1a2a55c (diff)
- Unbroken
- Make this port independence from www/py-webware - Determine what version to build by ${APACHE_VERSION}, gives compatibility with apache2x. Discussed with: pav
Notes
Notes: svn path=/head/; revision=201464
Diffstat (limited to 'www/mod_webkit/Makefile')
-rw-r--r--www/mod_webkit/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/www/mod_webkit/Makefile b/www/mod_webkit/Makefile
index c892f71a7a0d..e5191cfe90a4 100644
--- a/www/mod_webkit/Makefile
+++ b/www/mod_webkit/Makefile
@@ -6,26 +6,31 @@
#
PORTNAME= mod_webkit
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.4
CATEGORIES= www
-MASTER_SITES= # none
-DISTFILES= # none
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= webware
+DISTNAME= Webware-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A apache module for WebWare WebKit AppServer
-PATCH_DEPENDS= ${NONEXISTENT}:${WEBWARE_PORT}:extract
+USE_APACHE= 1.3+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
-BROKEN= does not build
+.include <bsd.port.pre.mk>
-USE_APACHE= 1.3
+.if ${APACHE_VERSION} >= 20
+PKGNAMESUFFIX= -ap2
+APACHE_VER= 2
+.else
+APACHE_VER= 1
+.endif
-WEBWARE_PORT= ${PORTSDIR}/www/py-webware
-WRKSRC= ${WRKDIR}/../../../www/py-webware/work/Webware-${PORTVERSION}/WebKit/Adapters/${PORTNAME}
-
-PLIST_FILES= libexec/apache/mod_webkit.so
+WRKSRC= ${WRKDIR}/Webware-${PORTVERSION}/WebKit/Adapters/${PORTNAME}${APACHE_VER}
post-patch:
@${REINPLACE_CMD} -e 's|/usr/sbin/apxs|${APXS}|' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>