aboutsummaryrefslogtreecommitdiff
path: root/www/mod_wsgi3
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2010-07-15 22:29:46 +0000
committerXin LI <delphij@FreeBSD.org>2010-07-15 22:29:46 +0000
commit738260c533674c6e97193394d56728720029305f (patch)
treec7c7d2391066e559de0ca8ae0e54a9f29ca54d03 /www/mod_wsgi3
parent0bb451b0afad6e11bbb827ed457ddfaa01ddeb86 (diff)
downloadports-738260c533674c6e97193394d56728720029305f.tar.gz
ports-738260c533674c6e97193394d56728720029305f.zip
Notes
Diffstat (limited to 'www/mod_wsgi3')
-rw-r--r--www/mod_wsgi3/Makefile1
-rw-r--r--www/mod_wsgi3/files/patch-mod_wsgi.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/www/mod_wsgi3/Makefile b/www/mod_wsgi3/Makefile
index abbeba0ee505..c51409659392 100644
--- a/www/mod_wsgi3/Makefile
+++ b/www/mod_wsgi3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_wsgi
PORTVERSION= 3.2
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
http://apt.douglasthrift.net/files/${PORTNAME}/ \
diff --git a/www/mod_wsgi3/files/patch-mod_wsgi.c b/www/mod_wsgi3/files/patch-mod_wsgi.c
new file mode 100644
index 000000000000..d9c9992bbe99
--- /dev/null
+++ b/www/mod_wsgi3/files/patch-mod_wsgi.c
@@ -0,0 +1,29 @@
+--- ./mod_wsgi.c.orig 2010-03-09 01:48:50.000000000 -0800
++++ ./mod_wsgi.c 2010-07-15 12:31:01.189153878 -0700
+@@ -5648,6 +5648,26 @@
+ module = PyImport_ImportModule("atexit");
+ Py_XDECREF(module);
+
++ /*
++ * In Python 2.6.5 and Python 3.1.2 the shutdown of
++ * threading was moved back into Py_Finalize() for the main
++ * Python interpreter. Because we shutting down threading
++ * ourselves, the second call results in errors being logged
++ * when Py_Finalize() is called and the shutdown function
++ * called a second time. The errors don't indicate any real
++ * problem and the threading module ignores them anyway.
++ * Whether we are using Python with this changed behaviour
++ * can only be checked by looking at run time version.
++ * Rather than try and add a dynamic check, create a fake
++ * 'dummy_threading' module as the presence of that shuts up
++ * the messages. It doesn't matter that the rest of the
++ * shutdown function still runs as everything is already
++ * stopped so doesn't do anything.
++ */
++
++ if (!PyImport_AddModule("dummy_threading"))
++ PyErr_Clear();
++
+ Py_Finalize();
+
+ wsgi_python_initialized = 0;