aboutsummaryrefslogtreecommitdiff
path: root/www/mod_wsgi4
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2015-07-12 10:04:30 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2015-07-12 10:04:30 +0000
commitd238fbc0a0633f82380922dcf4c78100e5e30410 (patch)
treec0a67cb6bfff9c8ad651174f80500dede5ef0482 /www/mod_wsgi4
parent31aa8fcaa98514fe370c4505b7f46ab26d19ae06 (diff)
downloadports-d238fbc0a0633f82380922dcf4c78100e5e30410.tar.gz
ports-d238fbc0a0633f82380922dcf4c78100e5e30410.zip
Notes
Diffstat (limited to 'www/mod_wsgi4')
-rw-r--r--www/mod_wsgi4/Makefile37
-rw-r--r--www/mod_wsgi4/distinfo2
-rw-r--r--www/mod_wsgi4/files/pkg-message.in8
-rw-r--r--www/mod_wsgi4/pkg-descr7
-rw-r--r--www/mod_wsgi4/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/www/mod_wsgi4/Makefile b/www/mod_wsgi4/Makefile
new file mode 100644
index 000000000000..b4f5bb15f6a8
--- /dev/null
+++ b/www/mod_wsgi4/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= mod_wsgi
+PORTVERSION= 3.5
+CATEGORIES= www python
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Python WSGI adapter module for Apache
+
+LICENSE= APACHE20
+
+CONFLICTS_INSTALL=${PKGNAMEPREFIX}mod_wsgi2.* mod_wsgi2.* \
+ ${PKGNAMEPREFIX}mod_wsgi-2.* mod_wsgi-2.*
+
+PROJECTHOST= modwsgi
+
+USE_APACHE= 22+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= GrahamDumpleton
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}"
+
+SUB_FILES= pkg-message
+
+pre-everything::
+ @${ECHO_MSG} "======================= ATTENTION! ======================"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to use daemon mode you will need to make sure"
+ @${ECHO_MSG} "Apache and APR include thread support."
+ @${ECHO_MSG}
+ @${ECHO_MSG} "========================================================="
+
+.include <bsd.port.mk>
diff --git a/www/mod_wsgi4/distinfo b/www/mod_wsgi4/distinfo
new file mode 100644
index 000000000000..de433e0c8ad2
--- /dev/null
+++ b/www/mod_wsgi4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (GrahamDumpleton-mod_wsgi-3.5_GH0.tar.gz) = f0674c38f0f568ece55610bcc6a775c179835c4cba23aa7f876d2a2a8520bf93
+SIZE (GrahamDumpleton-mod_wsgi-3.5_GH0.tar.gz) = 135875
diff --git a/www/mod_wsgi4/files/pkg-message.in b/www/mod_wsgi4/files/pkg-message.in
new file mode 100644
index 000000000000..5c72392ba9d4
--- /dev/null
+++ b/www/mod_wsgi4/files/pkg-message.in
@@ -0,0 +1,8 @@
+============================================================================
+
+If you want to use daemon mode you will need to make sure Apache and APR
+include thread support.
+
+For more information, see http://www.modwsgi.org/wiki/InstallationOnFreeBSD.
+
+============================================================================
diff --git a/www/mod_wsgi4/pkg-descr b/www/mod_wsgi4/pkg-descr
new file mode 100644
index 000000000000..626edd10ab45
--- /dev/null
+++ b/www/mod_wsgi4/pkg-descr
@@ -0,0 +1,7 @@
+The mod_wsgi adapter is an Apache module that provides a WSGI compliant
+interface for hosting Python based web applications within Apache. The
+adapter is written completely in C code against the Apache C runtime and
+for hosting WSGI applications within Apache has a lower overhead than using
+existing WSGI adapters for mod_python or CGI.
+
+WWW: http://www.modwsgi.org/
diff --git a/www/mod_wsgi4/pkg-plist b/www/mod_wsgi4/pkg-plist
new file mode 100644
index 000000000000..7e126d265e57
--- /dev/null
+++ b/www/mod_wsgi4/pkg-plist
@@ -0,0 +1,4 @@
+@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_wsgi-related directives in your httpd.conf"