aboutsummaryrefslogtreecommitdiff
path: root/www/mod_wsgi4
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2015-07-12 10:09:36 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2015-07-12 10:09:36 +0000
commitfd0b0c16e477d00867e1882eb661dfaa47f48391 (patch)
treefac6fb97070472d600f4828ad1a8ae3e401cd914 /www/mod_wsgi4
parentd238fbc0a0633f82380922dcf4c78100e5e30410 (diff)
downloadports-fd0b0c16e477d00867e1882eb661dfaa47f48391.tar.gz
ports-fd0b0c16e477d00867e1882eb661dfaa47f48391.zip
Notes
Diffstat (limited to 'www/mod_wsgi4')
-rw-r--r--www/mod_wsgi4/Makefile16
-rw-r--r--www/mod_wsgi4/distinfo4
-rw-r--r--www/mod_wsgi4/files/270_mod_wsgi.conf.sample.in9
-rw-r--r--www/mod_wsgi4/pkg-descr2
-rw-r--r--www/mod_wsgi4/pkg-plist3
5 files changed, 24 insertions, 10 deletions
diff --git a/www/mod_wsgi4/Makefile b/www/mod_wsgi4/Makefile
index b4f5bb15f6a8..c4bbcad1d7c7 100644
--- a/www/mod_wsgi4/Makefile
+++ b/www/mod_wsgi4/Makefile
@@ -1,18 +1,17 @@
# $FreeBSD$
PORTNAME= mod_wsgi
-PORTVERSION= 3.5
+PORTVERSION= 4.4.13
CATEGORIES= www python
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
-PKGNAMESUFFIX= 3
+PKGNAMESUFFIX= 4
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
LICENSE= APACHE20
-CONFLICTS_INSTALL=${PKGNAMEPREFIX}mod_wsgi2.* mod_wsgi2.* \
- ${PKGNAMEPREFIX}mod_wsgi-2.* mod_wsgi-2.*
+CONFLICTS_INSTALL=${PKGNAMEPREFIX}mod_wsgi3.* mod_wsgi3.*
PROJECTHOST= modwsgi
@@ -24,7 +23,10 @@ GH_ACCOUNT= GrahamDumpleton
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}"
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message ${APMOD_FILE}
+APMOD_FILE= 270_${PORTNAME}.conf.sample
+PLIST_SUB+= APMOD_FILE=${APMOD_FILE}
+
pre-everything::
@${ECHO_MSG} "======================= ATTENTION! ======================"
@@ -34,4 +36,8 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "========================================================="
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${INSTALL_DATA} ${WRKDIR}/${APMOD_FILE} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${PORTNAME}.so
.include <bsd.port.mk>
diff --git a/www/mod_wsgi4/distinfo b/www/mod_wsgi4/distinfo
index de433e0c8ad2..f1ccc639f143 100644
--- a/www/mod_wsgi4/distinfo
+++ b/www/mod_wsgi4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GrahamDumpleton-mod_wsgi-3.5_GH0.tar.gz) = f0674c38f0f568ece55610bcc6a775c179835c4cba23aa7f876d2a2a8520bf93
-SIZE (GrahamDumpleton-mod_wsgi-3.5_GH0.tar.gz) = 135875
+SHA256 (GrahamDumpleton-mod_wsgi-4.4.13_GH0.tar.gz) = e7a84e4af0da953070ab993268118791c7d3c7383d99e8b1c2e0ff88eb29c286
+SIZE (GrahamDumpleton-mod_wsgi-4.4.13_GH0.tar.gz) = 631708
diff --git a/www/mod_wsgi4/files/270_mod_wsgi.conf.sample.in b/www/mod_wsgi4/files/270_mod_wsgi.conf.sample.in
new file mode 100644
index 000000000000..bc39734e7c98
--- /dev/null
+++ b/www/mod_wsgi4/files/270_mod_wsgi.conf.sample.in
@@ -0,0 +1,9 @@
+## $FreeBSD$
+## vim: set filetype=apache:
+##
+## module file for mod_wsgi
+##
+## PROVIDE: mod_wsgi
+## REQUIRE:
+
+#LoadModule wsgi_module %%APACHEMODDIR%%/mod_wsgi.so
diff --git a/www/mod_wsgi4/pkg-descr b/www/mod_wsgi4/pkg-descr
index 626edd10ab45..b8223f7bfdd5 100644
--- a/www/mod_wsgi4/pkg-descr
+++ b/www/mod_wsgi4/pkg-descr
@@ -4,4 +4,4 @@ adapter is written completely in C code against the Apache C runtime and
for hosting WSGI applications within Apache has a lower overhead than using
existing WSGI adapters for mod_python or CGI.
-WWW: http://www.modwsgi.org/
+WWW: https://github.com/GrahamDumpleton/mod_wsgi/
diff --git a/www/mod_wsgi4/pkg-plist b/www/mod_wsgi4/pkg-plist
index 7e126d265e57..3f4758591ee8 100644
--- a/www/mod_wsgi4/pkg-plist
+++ b/www/mod_wsgi4/pkg-plist
@@ -1,4 +1,3 @@
-@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+@sample %%APACHEETCDIR%%/modules.d/%%APMOD_FILE%%
%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
@unexec echo "Don't forget to remove all mod_wsgi-related directives in your httpd.conf"