aboutsummaryrefslogtreecommitdiff
path: root/www/mod_xmlns
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-22 07:49:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-22 07:49:29 +0000
commitd095bc77c6ee740dcf8ad07c1b368e6500fe981d (patch)
treef64568289f56cc643c22dc2e1d47090237a6d7e2 /www/mod_xmlns
parent6d29e03fa5638d8cc4c15f365f496e0bba95b489 (diff)
downloadports-d095bc77c6ee740dcf8ad07c1b368e6500fe981d.tar.gz
ports-d095bc77c6ee740dcf8ad07c1b368e6500fe981d.zip
Notes
Diffstat (limited to 'www/mod_xmlns')
-rw-r--r--www/mod_xmlns/Makefile40
-rw-r--r--www/mod_xmlns/distinfo6
-rw-r--r--www/mod_xmlns/pkg-descr5
-rw-r--r--www/mod_xmlns/pkg-plist3
4 files changed, 54 insertions, 0 deletions
diff --git a/www/mod_xmlns/Makefile b/www/mod_xmlns/Makefile
new file mode 100644
index 000000000000..2a07d02436b7
--- /dev/null
+++ b/www/mod_xmlns/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: mod_xmlns
+#
+# Date created: 10/01/2007
+# Whom: Dominic Marks <dom@goodforbusiness.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_xmlns
+PORTVERSION= 0.97
+CATEGORIES= www
+MASTER_SITES= http://apache.webthing.com/svn/apache/filters/xmlns/
+DISTFILES= xmlns.h mod_xmlns.c
+
+MAINTAINER= dom@helenmarks.co.uk
+COMMENT= Apache module for XML namespaces
+
+USE_GNOME= libxml2
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+XML2_INC= ${LOCALBASE}/include/libxml2
+XML2_LIB= ${LOCALBASE}/lib
+
+do-extract:
+ @${DO_NADA}
+
+pre-fetch:
+ @${MKDIR} ${WRKDIR}
+
+post-fetch:
+ @${CP} ${DISTDIR}/xmlns.h ${DISTDIR}/mod_xmlns.c ${WRKDIR}
+
+do-build:
+ @(cd ${WRKDIR} && ${APXS} -c -I ${XML2_INC} -L ${XML2_LIB} -lxml2 mod_xmlns.c)
+
+do-install:
+ @(cd ${WRKDIR} && ${APXS} -A -i mod_xmlns.la)
+
+.include <bsd.port.mk>
diff --git a/www/mod_xmlns/distinfo b/www/mod_xmlns/distinfo
new file mode 100644
index 000000000000..394ee8ec0fe9
--- /dev/null
+++ b/www/mod_xmlns/distinfo
@@ -0,0 +1,6 @@
+MD5 (xmlns.h) = 6d3327342b3a996aa6eb9fc77a79de25
+SHA256 (xmlns.h) = ad1a411990601c2b22e5f4d5d071f125d9d484a4fe364d87fb3251de2607490d
+SIZE (xmlns.h) = 5751
+MD5 (mod_xmlns.c) = 12e727481234a67e341218900a744941
+SHA256 (mod_xmlns.c) = 00f06b0a411ae0c1797258a24597869c381da9e1d62337139e055e5164dd355e
+SIZE (mod_xmlns.c) = 26454
diff --git a/www/mod_xmlns/pkg-descr b/www/mod_xmlns/pkg-descr
new file mode 100644
index 000000000000..f0cf7e7e65fd
--- /dev/null
+++ b/www/mod_xmlns/pkg-descr
@@ -0,0 +1,5 @@
+mod_xmlns adds XML Namespace support to Apache, and may form the basis
+of XML-driven publishing systems. It runs as an output filter, so it
+works automatically with any content generator.
+
+WWW: http://apache.webthing.com/mod_xmlns/
diff --git a/www/mod_xmlns/pkg-plist b/www/mod_xmlns/pkg-plist
new file mode 100644
index 000000000000..a99345f69dce
--- /dev/null
+++ b/www/mod_xmlns/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_xmlns.so
+@exec %D/sbin/apxs -e -A -n xmlns %D/%F
+@unexec %D/sbin/apxs -e -A -n xmlns %D/%F