aboutsummaryrefslogtreecommitdiff
path: root/www/moodle27
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-06-08 09:38:31 +0000
committerWen Heping <wen@FreeBSD.org>2014-06-08 09:38:31 +0000
commitb98dfa973294e2dd8428c18ae4b0bdc8e9141008 (patch)
tree184d205305b607f38fad0f97b66ea063fca41670 /www/moodle27
parent844141abb61c36f07511fe369c6156b7ee7c2b75 (diff)
downloadports-b98dfa973294e2dd8428c18ae4b0bdc8e9141008.tar.gz
ports-b98dfa973294e2dd8428c18ae4b0bdc8e9141008.zip
Notes
Diffstat (limited to 'www/moodle27')
-rw-r--r--www/moodle27/Makefile83
-rw-r--r--www/moodle27/distinfo2
-rw-r--r--www/moodle27/files/pkg-message.in61
-rw-r--r--www/moodle27/pkg-descr7
4 files changed, 153 insertions, 0 deletions
diff --git a/www/moodle27/Makefile b/www/moodle27/Makefile
new file mode 100644
index 000000000000..d3ebdfd42714
--- /dev/null
+++ b/www/moodle27/Makefile
@@ -0,0 +1,83 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+# $FreeBSD$
+
+PORTNAME= moodle
+PORTVERSION= 2.7
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable27/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+
+CONFLICTS= moodle-1.*.* moodle24-2.4.* moodle25-2.5.[0-9]* moodle26-2.6.[0-9]*
+
+USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
+ soap openssl simplexml spl dom json zip zlib hash
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_DEFINE= MYSQL PGSQL MSSQL LDAP MIMETEX
+OPTIONS_DEFAULT=MYSQL
+MSSQL_DESC= MS SQL Server support
+MIMETEX_DESC= mimeTeX filter functionality support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= mysqli
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MMSSQL}
+USE_PHP+= mssql
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_PHP+= ldap
+.endif
+
+.if ${PORT_OPTIONS:MMIMETEX}
+RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
+.endif
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+.if ${PORT_OPTIONS:MMIMETEX}
+ ${LN} -sf ${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi \
+ ${STAGEDIR}${PREFIX}/${MOODLEDIR}/filter/tex/mimetex.freebsd
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/moodle27/distinfo b/www/moodle27/distinfo
new file mode 100644
index 000000000000..68feecabbfea
--- /dev/null
+++ b/www/moodle27/distinfo
@@ -0,0 +1,2 @@
+SHA256 (moodle-2.7.tgz) = 55db4c841c1469577a1b1bdd031455767fe36f39866df51c76dddfc81a7f95b5
+SIZE (moodle-2.7.tgz) = 34676653
diff --git a/www/moodle27/files/pkg-message.in b/www/moodle27/files/pkg-message.in
new file mode 100644
index 000000000000..9380c51f6361
--- /dev/null
+++ b/www/moodle27/files/pkg-message.in
@@ -0,0 +1,61 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+ <Directory %%PREFIX%%/%%MOODLEDATADIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ http://docs.moodle.org/en/Upgrading
+ http://docs.moodle.org/en/Upgrading_to_Moodle_2.0
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle27/pkg-descr b/www/moodle27/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle27/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/