aboutsummaryrefslogtreecommitdiff
path: root/www/moodle28
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-11-17 14:11:06 +0000
committerWen Heping <wen@FreeBSD.org>2014-11-17 14:11:06 +0000
commit3f1033cc9d6c4fa47f2d0bda2a4a3e7b3a86c295 (patch)
tree5fc5fdecb2009d1ad2a25c9e551321ded0babb16 /www/moodle28
parent58bea54274f2783e053f8ac9903794e73402ab2e (diff)
downloadports-3f1033cc9d6c4fa47f2d0bda2a4a3e7b3a86c295.tar.gz
ports-3f1033cc9d6c4fa47f2d0bda2a4a3e7b3a86c295.zip
Notes
Diffstat (limited to 'www/moodle28')
-rw-r--r--www/moodle28/Makefile83
-rw-r--r--www/moodle28/distinfo2
-rw-r--r--www/moodle28/files/pkg-message.in66
-rw-r--r--www/moodle28/pkg-descr7
4 files changed, 158 insertions, 0 deletions
diff --git a/www/moodle28/Makefile b/www/moodle28/Makefile
new file mode 100644
index 000000000000..1f472a49c3ba
--- /dev/null
+++ b/www/moodle28/Makefile
@@ -0,0 +1,83 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+# $FreeBSD$
+
+PORTNAME= moodle
+PORTVERSION= 2.7.3
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable27/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+
+CONFLICTS= moodle26-2.6.[0-9]* moodle28-2.8.[0-9]*
+
+USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
+ soap openssl simplexml spl dom json zip zlib hash
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_DEFINE= MYSQL PGSQL MSSQL LDAP MIMETEX
+OPTIONS_DEFAULT=MYSQL
+MSSQL_DESC= MS SQL Server support
+MIMETEX_DESC= mimeTeX filter functionality support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= mysqli
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MMSSQL}
+USE_PHP+= mssql
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_PHP+= ldap
+.endif
+
+.if ${PORT_OPTIONS:MMIMETEX}
+RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
+.endif
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+.if ${PORT_OPTIONS:MMIMETEX}
+ ${LN} -sf ${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi \
+ ${STAGEDIR}${PREFIX}/${MOODLEDIR}/filter/tex/mimetex.freebsd
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/moodle28/distinfo b/www/moodle28/distinfo
new file mode 100644
index 000000000000..fbeea39e88c6
--- /dev/null
+++ b/www/moodle28/distinfo
@@ -0,0 +1,2 @@
+SHA256 (moodle-2.7.3.tgz) = baaf5a323d44417c40fd4104378426c18c80cf17db19180f76b2e3c2b5a40dc9
+SIZE (moodle-2.7.3.tgz) = 34891141
diff --git a/www/moodle28/files/pkg-message.in b/www/moodle28/files/pkg-message.in
new file mode 100644
index 000000000000..78e588e304d9
--- /dev/null
+++ b/www/moodle28/files/pkg-message.in
@@ -0,0 +1,66 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ For Apache versions earlier than 2.4:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+ For Apache version 2.4.x or above:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ http://docs.moodle.org/en/Upgrading
+ http://docs.moodle.org/en/Upgrading_to_Moodle_2.0
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle28/pkg-descr b/www/moodle28/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle28/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/