aboutsummaryrefslogtreecommitdiff
path: root/www/moodle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-28 12:33:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-28 12:33:21 +0000
commitf07eb6d78c184f5f6e8d9c37af031d9e3cd1995a (patch)
treea9e82b333caaa77c759200d0351654e40f171a86 /www/moodle
parent31870b4e570143f71e12537dd05bcc59adf731d7 (diff)
downloadports-f07eb6d78c184f5f6e8d9c37af031d9e3cd1995a.tar.gz
ports-f07eb6d78c184f5f6e8d9c37af031d9e3cd1995a.zip
Notes
Diffstat (limited to 'www/moodle')
-rw-r--r--www/moodle/Makefile51
-rw-r--r--www/moodle/distinfo6
-rw-r--r--www/moodle/files/pkg-message.in11
3 files changed, 49 insertions, 19 deletions
diff --git a/www/moodle/Makefile b/www/moodle/Makefile
index 0fd4be267f7e..100888cf6610 100644
--- a/www/moodle/Makefile
+++ b/www/moodle/Makefile
@@ -6,17 +6,40 @@
#
PORTNAME= moodle
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8
CATEGORIES= www
-MASTER_SITES= http://download.moodle.org/stable17/
+MASTER_SITES= http://download.moodle.org/stable18/
EXTRACT_SUFX= .tgz
MAINTAINER= jmrueda@diatel.upm.es
COMMENT= Course management system based on social constructionism
-USE_PHP= session gd pcre
+USE_PHP= session gd pcre mbstring iconv tokenizer curl xml
WRKSRC= ${WRKDIR}/moodle
+OPTIONS= MYSQL "Add support for a MySQL database server" Off \
+ PGSQL "Add support for a PostgreSQL database server" Off \
+ MSSQL "Add support for a MS SQL Server" Off \
+ ZLIB "Add zip/unzip functionality" On \
+ NETWORK "Add Moodle Network functionality" Off \
+ LDAP "Add LDAP authentication functionality" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_MSSQL)
+pre-fetch:
+ @${ECHO_MSG} "
+ @${ECHO_MSG} "You didn't activate support for any database server!"
+ @${ECHO_MSG} "
+ @${ECHO_MSG} "If you want to reconsider, press Ctrl-C now to cancel"
+ @${ECHO_MSG} "the installation and run 'make config'"
+ @${ECHO_MSG} "
+ @${ECHO_MSG} "You can also add the required PHP module later, if that's"
+ @${ECHO_MSG} "what you prefer."
+ @${ECHO_MSG} "
+ @sleep 5
+.endif
+
.if defined(WITH_MYSQL)
USE_PHP+= mysql
.endif
@@ -25,12 +48,22 @@ USE_PHP+= mysql
USE_PHP+= pgsql
.endif
+.if defined(WITH_MSSQL)
+USE_PHP+= mssql
+.endif
+
+.if !defined(WITHOUT_ZLIB)
+USE_PHP+= zlib
+.endif
+
+.if defined(WITH_NETWORK)
+USE_PHP+= curl openssl
+.endif
+
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif
-.include <bsd.port.pre.mk>
-
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
SUB_FILES= pkg-message
@@ -40,14 +73,6 @@ SUB_LIST= MOODLEDIR=${MOODLEDIR} \
MOODLEDIR?= www/moodle
MOODLEDATADIR?= www/moodledata
-pre-everything::
- @${ECHO_CMD} "===> You can use the following options:"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "o WITH_MYSQL - Use a MySQL database"
- @${ECHO_CMD} "o WITH_PGSQL - Use a pgSQL database"
- @${ECHO_CMD} "o WITH_LDAP - Ensure your PHP has ldap extension"
- @${ECHO_CMD} ""
-
pre-install:
@${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
@${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
diff --git a/www/moodle/distinfo b/www/moodle/distinfo
index bacfa5b5fa23..6a9cc2fbf27a 100644
--- a/www/moodle/distinfo
+++ b/www/moodle/distinfo
@@ -1,3 +1,3 @@
-MD5 (moodle-1.7.1.tgz) = 80e69370d56815eef5c6f422f8fc5a44
-SHA256 (moodle-1.7.1.tgz) = f9b4a7ecf0cd6b5deaea3570ecde8f048b7e647fe915369a96cbf3d3b6fc11dc
-SIZE (moodle-1.7.1.tgz) = 9591469
+MD5 (moodle-1.8.tgz) = dc58848eb315fbf3173d6f2318c0a28d
+SHA256 (moodle-1.8.tgz) = 6ac3d3ca631e1fe2b315c1508e0d1e68224d652ce16d4387dc1877f847ab01ef
+SIZE (moodle-1.8.tgz) = 10104918
diff --git a/www/moodle/files/pkg-message.in b/www/moodle/files/pkg-message.in
index 148a93cbf668..31086814285b 100644
--- a/www/moodle/files/pkg-message.in
+++ b/www/moodle/files/pkg-message.in
@@ -5,8 +5,8 @@ POST-INSTALL CONFIGURATION FOR MOODLE
its tables in (or choose an existing database).
It doesn't matter what the database or user names are,
as this will be configured in a later step.
- NOTE: this package assumes that either the phpX-pgsql
- or phpX-mysql packages are installed, as needed.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
2) Add the following to your Apache configuration, and
restart the server:
@@ -47,10 +47,15 @@ For more information, see the INSTALL DOCUMENTATION:
http://docs.moodle.org/en/Installing_Moodle
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
If you are upgrading from an earlier version of Moodle, check out
possible additional steps at:
- http://docs.moodle.org/en/Upgrading_to_Moodle_1.7
+ http://docs.moodle.org/en/Upgrading
+ http://docs.moodle.org/en/Upgrading_to_Moodle_1.8
If you have real trouble, please visit the Moodle course
"Using Moodle" on moodle.org.