aboutsummaryrefslogtreecommitdiff
path: root/www/mozex/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-09-06 06:45:02 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-09-06 06:45:02 +0000
commit9adcc4e9d6145ec9e051bc9ce75fcea84fdfa34f (patch)
treea8e84d73f1c63efb783c4c3d4a64e635f00461ae /www/mozex/Makefile
parentdabdff80f93f9e87dd13f4c1b5d2141fb79322d8 (diff)
downloadports-9adcc4e9d6145ec9e051bc9ce75fcea84fdfa34f.tar.gz
ports-9adcc4e9d6145ec9e051bc9ce75fcea84fdfa34f.zip
Notes
Diffstat (limited to 'www/mozex/Makefile')
-rw-r--r--www/mozex/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/mozex/Makefile b/www/mozex/Makefile
index 0931274d0c86..8bac7822c053 100644
--- a/www/mozex/Makefile
+++ b/www/mozex/Makefile
@@ -5,21 +5,31 @@
# $FreeBSD$
#
-PORTNAME?= mozex
+PORTNAME= mozex
PORTVERSION= 1.07
-PORTREVISION?= 3
+PORTREVISION= 4
CATEGORIES= www mail news ftp
MASTER_SITES= ${MASTER_SITE_MOZDEV}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER?= ports@FreeBSD.org
-COMMENT?= Mozex allows Mozilla's users to use external programs for mail, news, etc.
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Mozex allows users of ${GEKO} to use external programs for mail, news, etc.
USE_X_PREFIX= yes # Cannot be included after <bsd.port.pre.mk>.
+SUB_FILES= pkg-message
+SUB_LIST= GECKO=${GECKO}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_FILES= %%MOZDIR%%/chrome/mozex.jar
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozex/Makefile.xpi"
+.if ${GECKO} == mozilla
+PLIST_FILES+= %%MOZDIR%%/chrome/overlayinfo/browser/content/overlays.rdf
+.endif
+
do-install:
@${INSTALL_DATA} ${WRKDIR}/mozex.jar ${MOZDIR}/chrome