aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla-bonobo
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-02-18 03:50:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-02-18 03:50:38 +0000
commit7602ef6eba2985340514708df571c5615af0628c (patch)
tree15c4c362da46e9feacd3a33331562d61fca1edb6 /www/mozilla-bonobo
parent60049684ec6bcbccddf486543942c9cea25eb629 (diff)
GTK2 mozilla is now the default, and GTK1 support will be built only if explicitly
requested. This means that mozilla-gtk2 and mozilla-devel-gtk2 are now mozilla and mozilla-devel, respectively; and the old mozilla and mozilla-devel are now mozilla-gtk1 and mozilla-devel-gtk1. This is done for a whole plethora of reasons, and should please everybody except galeon1 fanatics and uhm... anybody else who it doesn't please. If you have WITH_MOZILLA set in your /etc/make.conf, you'll need to update the value accordingly. GTK2 ports will automatically install GTK2 mozilla, and GTK1 ports will automatically install GTK1 ports, so WITH_MOZILLA need be defined only if you want the development version... which are dormant right now anyway. For now, all ports that honoured WITH_MOZILLA=mozilla-{,-devel}-gtk2 will still honour those values as well as WITH_MOZILLA=mozilla{,-devel}, but future ports reserve the right to ignore the *-gtk2 values.
Notes
Notes: svn path=/head/; revision=101293
Diffstat (limited to 'www/mozilla-bonobo')
-rw-r--r--www/mozilla-bonobo/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/mozilla-bonobo/Makefile b/www/mozilla-bonobo/Makefile
index 882e6cee2005..38978adabec5 100644
--- a/www/mozilla-bonobo/Makefile
+++ b/www/mozilla-bonobo/Makefile
@@ -18,18 +18,18 @@ COMMENT= A Netscape/Mozilla plugin using Bonobo controls to display files
BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif
@@ -44,10 +44,10 @@ CONFIGURE_ARGS= --with-plugin-install-dir="${PREFIX}/lib/browser_plugins" \
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default mozilla-bonobo uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " By default mozilla-bonobo uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG} ""
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-patch: