aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla-devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-27 22:48:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-27 22:48:54 +0000
commitc5ed87bd0318668fce24ba4210c02287cc790fa6 (patch)
treed3635ba2682fda67b33532b4eb25c56c9ef5b755 /www/mozilla-devel
parent60e37192e41aeb21edc33b605348a0c5d8eea849 (diff)
downloadports-c5ed87bd0318668fce24ba4210c02287cc790fa6.tar.gz
ports-c5ed87bd0318668fce24ba4210c02287cc790fa6.zip
Notes
Diffstat (limited to 'www/mozilla-devel')
-rw-r--r--www/mozilla-devel/Makefile2
-rw-r--r--www/mozilla-devel/files/mozilla.sh19
2 files changed, 13 insertions, 8 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 7ef9a86ffacd..48cc223aeaf7 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.2b
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla-devel/files/mozilla.sh b/www/mozilla-devel/files/mozilla.sh
index 0e34950cd32c..bbc7d2568bc6 100644
--- a/www/mozilla-devel/files/mozilla.sh
+++ b/www/mozilla-devel/files/mozilla.sh
@@ -6,13 +6,18 @@ LOCATION='new-tab'
cd $MOZILLA_DIR || exit 1
-# catch calls for mozilla mail
-if [ "$1" = "-mail" ]; then
- REMOTE_COMMAND="xfeDoCommand (openInbox)"
-else
- REMOTE_COMMAND="openURL($@, $LOCATION)"
-fi
-
+case $1 in
+ -mail)
+ REMOTE_COMMAND="xfeDoCommand (openInbox)"
+ ;;
+ -*)
+ exec ./$MOZILLA_EXEC "$@"
+ ;;
+ *)
+ REMOTE_COMMAND="openURL($@, $LOCATION)"
+ ;;
+esac
+
# process found
./$MOZILLA_EXEC -remote "ping()" &&
./$MOZILLA_EXEC -remote "$REMOTE_COMMAND" && exit 0