aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-20 20:26:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-20 20:26:40 +0000
commit8240376fa721e1ea64180d28ba01b0acfbbd5f34 (patch)
tree8dcf06605e9b6df4870203952b7329101efa55d4 /www/mozilla/files
parente0d995bc3632e9dfccd155394bb4e244bacfce58 (diff)
downloadports-8240376fa721e1ea64180d28ba01b0acfbbd5f34.tar.gz
ports-8240376fa721e1ea64180d28ba01b0acfbbd5f34.zip
Notes
Diffstat (limited to 'www/mozilla/files')
-rw-r--r--www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc11
-rw-r--r--www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in33
-rw-r--r--www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcinvoke_asm_ipf64.s19
-rw-r--r--www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcstubs_asm_ipf64.s19
-rw-r--r--www/mozilla/files/patch-xptcall-sparc6418
5 files changed, 82 insertions, 18 deletions
diff --git a/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc b/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
new file mode 100644
index 000000000000..ed281efd9234
--- /dev/null
+++ b/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
@@ -0,0 +1,11 @@
+--- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Sun Jul 20 11:45:41 2003
++++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Sun Jul 20 11:49:09 2003
+@@ -8,7 +8,7 @@
+ * 1 is AddRef
+ * 2 is Release
+ */
+-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
++#if !defined(__ia64)
+ XPTC_EXPORT NS_IMETHOD Stub3();
+ XPTC_EXPORT NS_IMETHOD Stub4();
+ XPTC_EXPORT NS_IMETHOD Stub5();
diff --git a/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in
new file mode 100644
index 000000000000..d1d0dc6f6732
--- /dev/null
+++ b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in
@@ -0,0 +1,33 @@
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Sat Jul 19 22:50:35 2003
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sat Jul 19 23:46:56 2003
+@@ -59,13 +59,11 @@
+ CPPSRCS := xptcinvoke_gcc_x86_unix.cpp xptcstubs_gcc_x86_unix.cpp
+ endif
+ endif
+-# IA64 Linux
+-ifneq (,$(filter Linux,$(OS_ARCH)))
++# IA64 Linux & FreeBSD
+ ifneq (,$(findstring ia64,$(OS_TEST)))
+ CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
+ ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
+ endif
+-endif
+ #
+ # BeOS/Intel (uses the same unixish_x86 code)
+ #
+@@ -298,6 +296,15 @@
+ ifeq ($(OS_ARCH)$(OS_TEST),NetBSDsparc)
+ CPPSRCS := xptcinvoke_sparc_netbsd.cpp xptcstubs_sparc_netbsd.cpp
+ ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
++endif
++#
++# FreeBSD/SPARC64
++#
++ifeq ($(OS_ARCH),FreeBSD)
++ifneq (,$(findstring sparc,$(OS_TEST)))
++CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
++ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
++endif
+ endif
+ #
+ # Solaris/SPARC
diff --git a/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcinvoke_asm_ipf64.s b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcinvoke_asm_ipf64.s
new file mode 100644
index 000000000000..24ad08585a6b
--- /dev/null
+++ b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcinvoke_asm_ipf64.s
@@ -0,0 +1,19 @@
+--- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_ipf64.s.orig Sun Jul 20 00:05:32 2003
++++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_ipf64.s Sun Jul 20 00:06:37 2003
+@@ -8,6 +8,7 @@
+ // Section has executable code
+ .section .text, "ax","progbits"
+ // procedure named 'XPTC_InvokeByIndex'
++ .global XPTC_InvokeByIndex
+ .proc XPTC_InvokeByIndex
+ // manual bundling
+ .explicit
+@@ -24,7 +25,7 @@
+
+ // XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
+ // PRUint32 paramCount, nsXPTCVariant* params);
+-XPTC_InvokeByIndex::
++XPTC_InvokeByIndex:
+ .prologue
+ .save ar.pfs, r37
+ // allocate 4 input args, 6 local args, and 8 output args
diff --git a/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcstubs_asm_ipf64.s b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcstubs_asm_ipf64.s
new file mode 100644
index 000000000000..bc5cd67e24f8
--- /dev/null
+++ b/www/mozilla/files/patch-xpcom::reflect::xptcall::src::md::unix::xptcstubs_asm_ipf64.s
@@ -0,0 +1,19 @@
+--- xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ipf64.s.orig Sun Jul 20 00:02:02 2003
++++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_asm_ipf64.s Sun Jul 20 00:02:40 2003
+@@ -6,6 +6,7 @@
+ // Section has executable code
+ .section .text, "ax","progbits"
+ // procedure named 'SharedStub'
++ .global SharedStub
+ .proc SharedStub
+ // manual bundling
+ .explicit
+@@ -14,7 +15,7 @@
+ // .exclass PrepareAndDispatch, @fullyvisible
+ .type PrepareAndDispatch,@function
+
+-SharedStub::
++SharedStub:
+ // 9 arguments, first 8 are the input arguments of previous
+ // function call. The last one is methodIndex, and is passed in memory
+ .prologue
diff --git a/www/mozilla/files/patch-xptcall-sparc64 b/www/mozilla/files/patch-xptcall-sparc64
index ea2773ced7d9..9599a8a71336 100644
--- a/www/mozilla/files/patch-xptcall-sparc64
+++ b/www/mozilla/files/patch-xptcall-sparc64
@@ -1,21 +1,3 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Mon May 26 13:26:01 2003
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Mon May 26 13:30:04 2003
-@@ -287,6 +287,15 @@
- ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
- endif
- #
-+# FreeBSD/SPARC64
-+#
-+ifeq ($(OS_ARCH),FreeBSD)
-+ifneq (,$(findstring sparc,$(OS_TEST)))
-+CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
-+ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
-+endif
-+endif
-+#
- # Solaris/SPARC
- #
- ifeq ($(OS_ARCH),SunOS)
--- /dev/null Mon May 26 13:22:00 2003
+++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_sparc64_freebsd.cpp Mon May 26 04:12:55 2003
@@ -0,0 +1,123 @@