aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-26 04:17:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-26 04:17:52 +0000
commitb19b696d630c476aa4ff5c4631807bd28e5f901e (patch)
tree2626a1467c4d3c3e532325862a21735ce9828aa0 /www/mozilla
parentab743df86140856bfdfd24a86a8798a3b7a26080 (diff)
downloadports-b19b696d630c476aa4ff5c4631807bd28e5f901e.tar.gz
ports-b19b696d630c476aa4ff5c4631807bd28e5f901e.zip
Notes
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>