aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-12-04 22:05:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-12-04 22:05:43 +0000
commit4835940e84c5cbcbf8b2d7609265b5b2dd9079a6 (patch)
tree940a8fbad7656ce9fe892a5baade3624866aaeef /www/mozilla
parent48214282617dc951b3a0589ac10004f0114405ae (diff)
- Add support for GECKO_PLIST_PRE_FILES and GECKO_PLIST_PRE_DIRS to
add files or directories to plist. - *Really* remove share/idl if empty in firefox
Notes
Notes: svn path=/head/; revision=150419
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile.common9
1 files changed, 9 insertions, 0 deletions
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index 20395a8677dc..5058bcf8c755 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -15,6 +15,9 @@
#
# Ports can use the following:
#
+# GECKO_PLIST_PRE_FILES List of files to add to the beginning of plist
+# GECKO_PLIST_PRE_DIRS
+#
# MOZILLA_PLIST_DIRS List of directories to descend into when
# installing and creating the plist
# MOZ_PIS_SCRIPTS List of scripts residing in ${FILESDIR} to
@@ -316,6 +319,12 @@ gecko-create-plist:
${FAKEDIR}/bin/${MOZILLA}-config
${RM} -f ${FAKEDIR}/bin/*.bak
# Create the plist
+.for f in ${GECKO_PLIST_PRE_FILES}
+ ${ECHO_CMD} ${f} >> ${PLIST}
+.endfor
+.for f in ${GECKO_PLIST_PRE_DIRS}
+ ${ECHO_CMD} "@dirrm ${f}" >> ${PLIST}
+.endfor
${ECHO_CMD} "${BROWSER_PLUGINS_DIR}/.${MOZILLA}.keep" >> ${PLIST}
${ECHO_CMD} "@unexec ${RMDIR} %D/${BROWSER_PLUGINS_DIR} 2>/dev/null || ${TRUE}" >> ${PLIST}
${MKDIR} ${FAKEDIR}/libdata