aboutsummaryrefslogtreecommitdiff
path: root/www/mozilla
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /www/mozilla
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile6
-rw-r--r--www/mozilla/Makefile.common68
-rw-r--r--www/mozilla/bsd.gecko.mk20
-rw-r--r--www/mozilla/files/patch-gfx_src_ps_nsType1.cpp58
-rw-r--r--www/mozilla/pkg-deinstall.in4
-rw-r--r--www/mozilla/pkg-install.in4
6 files changed, 121 insertions, 39 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 2ac5c3e029bd..f646e50a54d4 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,12 +3,11 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile,v 1.36 2006/03/09 00:45:43 ahze Exp $
-#
+# $MCom: ports/www/mozilla/Makefile,v 1.38 2006/07/18 15:03:40 ahze Exp $
PORTNAME= mozilla
PORTVERSION= 1.7.13
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -24,7 +23,6 @@ COMMENT= The open source, standards compliant web browser
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/dist/bin
USE_GMAKE= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
WANT_GNOME= yes
HAS_CONFIGURE= yes
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index ae9bebd996c1..540aeaac9fa4 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -4,7 +4,7 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile.common,v 1.20 2006/03/09 00:45:43 ahze Exp $
+# $MCom: ports/www/mozilla/Makefile.common,v 1.31 2006/10/14 03:49:21 ahze Exp $
# This file contains some reusable components for mozilla ports. It's of
# use primarily to apps from the mozilla project itself (such as Firefox,
@@ -59,10 +59,6 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
nss3:${PORTSDIR}/security/nss \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-OPTIONS+= DEBUG "Build a debugging image" off \
- LOGGING "Enable additional log messages" off \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off
-
MAINTAINER?= gnome@FreeBSD.org
MOZILLA?= ${PORTNAME}
@@ -72,7 +68,7 @@ MOZ_RPATH?= ${MOZILLA}
USE_GNOME+= gtk20 libidl desktopfileutils
USE_ICONV= yes
USE_PERL5_BUILD=yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
MOZILLA_SUFX?= none
WRKSRC?= ${WRKDIR}/mozilla
@@ -108,7 +104,6 @@ EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --exclude */CVS/* \
--exclude mozilla/modules/libimg/png \
--exclude mozilla/jpeg \
--exclude mozilla/dbm \
- --exclude mozilla/js/src/fdlibm \
--exclude mozilla/security/nss \
--exclude mozilla/gc/boehm \
--exclude mozilla/gfx/cairo
@@ -125,6 +120,23 @@ CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${X11BASE}/lib -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
LIBS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv
+_USE_GECKO_OPTIONS_ALL= java debug logging optimized_cflags
+
+.if !defined(USE_GECKO_OPTIONS)
+USE_GECKO_OPTIONS= debug logging optimized_cflags
+.endif
+
+debug_OPTION= "Build a debugging image" off
+java_OPTION= "Enable JAVA xpcom" off
+logging_OPTION= "Enable additional log messages" off
+optimized_cflags_OPTION= "Enable some additional optimizations" off
+
+.for option in ${USE_GECKO_OPTIONS:L}
+.if ${_USE_GECKO_OPTIONS_ALL:M${option}}!=""
+OPTIONS+= ${option:U} ${${option}_OPTION}
+.endif
+.endfor
+
# Standard options from README
MOZ_OPTIONS+= --enable-crypto \
--disable-tests \
@@ -172,20 +184,13 @@ MOZ_OPTIONS+= --with-system-jpeg=${LOCALBASE} \
--enable-xinerama
MOZ_MK_OPTIONS+= XP_UNIX=1 \
PERL=${PERL}
-#MOZ_EXPORT+= CPPFLAGS=${CPPFLAGS} \
-# CFLAGS=$$CFLAGS \
-# LIBS=$$LIBS \
-# LDFLAGS=$$LDFLAGS \
-# CONFIG_SH=$$SH \
-# XP_UNIX=1 \
-# PERL=$$PERL5
.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS:= -O2 -fno-strict-aliasing ${CFLAGS:N-O*}
+CFLAGS:= ${CFLAGS} -O2 -fno-strict-aliasing ${EXTRA_CFLAGS}
WITH_OPTIMIZE?= -O2
.else
-CFLAGS:= ${CFLAGS:N-O*:N-m*} -O
-WITH_OPTIMIZE?= -O
+CFLAGS:= ${CFLAGS} ${EXTRA_CFLAGS}
+WITH_OPTIMIZE?=
.endif
.if defined(WITH_SMB)
@@ -203,6 +208,14 @@ MOZ_OPTIONS+= --disable-debug \
--enable-strip
.endif
+.if defined(WITH_JAVA)
+USE_JAVA= yes
+JAVA_VERSION+= 1.4+
+JAVA_OS+= native
+CONFIGURE_ENV+= JAVA_HOME="${JAVA_HOME}"
+MOZ_OPTIONS+= --enable-javaxpcom
+.endif
+
.if defined(WITH_LOGGING)
MOZ_OPTIONS+= --enable-logging
.else
@@ -289,7 +302,7 @@ gecko-post-patch:
@${REINPLACE_CMD} -E -e 's|libesd\.so\.[0-9]+|libesd.so|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
@${REINPLACE_CMD} -E -e 's|libcups\.so\.[0-9]+|libcups.so|g' \
- ${WRKSRC}/gfx/src/gtk/nsDeviceContextSpecG.cpp
+ ${WRKSRC}/*/*/*/nsDeviceContextSpecG.cpp
@${REINPLACE_CMD} -e 's|/usr/local/netscape|${LOCALBASE}|g ; \
s|/usr/local/lib/netscape|${LOCALBASE}/lib|g' \
${WRKSRC}/xpcom/*/SpecialSystemDirectory.cpp
@@ -304,18 +317,25 @@ gecko-moz-pis-patch:
@${MOZCONFIG_SED} < ${FILESDIR}/${moz} > ${WRKDIR}/${moz}
.endfor
+post-configure: gecko-post-configure
+
+gecko-post-configure:
+ @${ECHO_CMD} "#define JNIIMPORT" >> ${WRKSRC}/mozilla-config.h
+
post-build: gecko-post-build
gecko-post-build:
@${REINPLACE_CMD} -e "s|\(Libs:.*\)\($$\)|\1 -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}\2|" \
${WRKSRC}/build/unix/*.pc
-pre-install: gecko-pre-install gecko-moz-pis-pre-install gecko-create-plist
+pre-install: gecko-moz-pis-pre-install gecko-pre-install port-pre-install gecko-create-plist
-gecko-pre-install:
- @${DO_NADA} # Empty for now
+.if !target(port-pre-install)
+port-pre-install:
+ @${DO_NADA}
+.endif
-gecko-create-plist:
+gecko-pre-install:
.if !defined(NOGECKO_PLIST)
@${RM} -rf ${FAKEDIR} ${PLIST}
@${TOUCH} -f ${PLIST}
@@ -337,6 +357,10 @@ gecko-create-plist:
${FAKEDIR}/bin/${MOZILLA} \
${FAKEDIR}/bin/${MOZILLA}-config
${RM} -f ${FAKEDIR}/bin/*.bak
+.endif
+
+gecko-create-plist:
+.if !defined(NOGECKO_PLIST)
# Create the plist
.for f in ${GECKO_PLIST_PRE_FILES}
${ECHO_CMD} ${f} >> ${PLIST}
diff --git a/www/mozilla/bsd.gecko.mk b/www/mozilla/bsd.gecko.mk
index e74ccb1d4831..10dd6ef7d966 100644
--- a/www/mozilla/bsd.gecko.mk
+++ b/www/mozilla/bsd.gecko.mk
@@ -2,7 +2,7 @@
# ex:ts=4
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.17 2006/03/10 12:42:50 ahze Exp $
+# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.26 2006/10/13 04:20:21 ahze Exp $
#
# 4 column tabs prevent hair loss and tooth decay!
@@ -69,19 +69,17 @@ Gecko_Pre_Include= bsd.gecko.mk
.if ${OSVERSION} >= 500000
.if (${ARCH}!="sparc64" || ${OSVERSION} >= 601101) && ${ARCH}!="ia64"
-_GECKO_ALL= firefox nvu seamonkey sunbird thunderbird xulrunner firefox-devel flock
+_GECKO_ALL= firefox nvu seamonkey thunderbird xulrunner firefox-devel flock
.endif
.endif
_GECKO_ALL+= mozilla
-sunbird_PORTSDIR= deskutils
-
thunderbird_PORTSDIR= mail
.for gecko in ${_GECKO_ALL}
${gecko}_PORTSDIR?= www
${gecko}_DEPENDS?= ${PORTSDIR}/${${gecko}_PORTSDIR}/${gecko}
-${gecko}_PLIST?= ${X11BASE}/lib/${gecko}/libgtkembedmoz.so
+${gecko}_PLIST?= ${LOCALBASE}/lib/${gecko}/libgtkembedmoz.so
.endfor
# Figure out which mozilla to use
@@ -125,18 +123,18 @@ GECKO_FALLTRHOUGH= ${TRUE}
.endif
# Generic defines
-BROWSER_LINUX_PLUGINS_DIR?= ${X11BASE}/lib/browser_linux_plugins
-BROWSER_PLUGINS_DIR?= ${X11BASE}/lib/browser_plugins
+BROWSER_LINUX_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_linux_plugins
+BROWSER_PLUGINS_DIR?= ${LOCALBASE}/lib/browser_plugins
-GECKO_CONFIG?= ${X11BASE}/bin/${GECKO}-config
-XPIDL?= ${X11BASE}/lib/${GECKO}/xpidl
+GECKO_CONFIG?= ${LOCALBASE}/bin/${GECKO}-config
+XPIDL?= ${LOCALBASE}/lib/${GECKO}/xpidl
XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
.if defined(GECKO) && ${_GECKO_ALL:M${GECKO}}!=""
BUILD_DEPENDS+= ${${GECKO}_PLIST}:${${GECKO}_DEPENDS}
RUN_DEPENDS+= ${${GECKO}_PLIST}:${${GECKO}_DEPENDS}
.else
-BROKEN=Unable to find a supported gecko, please check USE_GECKO
+IGNORE= Unable to find a supported gecko, please check USE_GECKO
.endif
pre-everything:: _gecko-pre-everything
@@ -164,7 +162,7 @@ post-patch: gecko-post-patch
gecko-post-patch:
.if defined(${GECKO}_HACK)
- ${FIND} ${WRKSRC} -name "Makefile.in" -o -name "configure" | \
+ ${FIND} ${WRKSRC} -name "Makefile.in" -type f -o -name "configure" -type f | \
${XARGS} ${REINPLACE_CMD} -e ${${GECKO}_HACK}
.endif
diff --git a/www/mozilla/files/patch-gfx_src_ps_nsType1.cpp b/www/mozilla/files/patch-gfx_src_ps_nsType1.cpp
new file mode 100644
index 000000000000..29752f34a181
--- /dev/null
+++ b/www/mozilla/files/patch-gfx_src_ps_nsType1.cpp
@@ -0,0 +1,58 @@
+--- gfx/src/ps/nsType1.cpp.orig Wed Dec 11 01:24:47 2002
++++ gfx/src/ps/nsType1.cpp Sun Sep 10 09:52:45 2006
+@@ -81,8 +81,8 @@
+ int wmode;
+ } FT2PT1_info;
+
+-static int cubicto(FT_Vector *aControlPt1, FT_Vector *aControlPt2,
+- FT_Vector *aEndPt, void *aClosure);
++static int cubicto(const FT_Vector *aControlPt1, const FT_Vector *aControlPt2,
++ const FT_Vector *aEndPt, void *aClosure);
+ static int Type1CharStringCommand(unsigned char **aBufPtrPtr, int aCmd);
+ static int Type1EncodeCharStringInt(unsigned char **aBufPtrPtr, int aValue);
+
+@@ -173,7 +173,7 @@
+ }
+
+ static PRBool
+-sideWidthAndBearing(FT_Vector *aEndPt, FT2PT1_info *aFti)
++sideWidthAndBearing(const FT_Vector *aEndPt, FT2PT1_info *aFti)
+ {
+ int aw = 0;
+ int ah = 0;
+@@ -216,7 +216,7 @@
+ }
+
+ static int
+-moveto(FT_Vector *aEndPt, void *aClosure)
++moveto(const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *fti = (FT2PT1_info *)aClosure;
+ FT_UShort upm = fti->face->units_per_EM;
+@@ -253,7 +253,7 @@
+ }
+
+ static int
+-lineto(FT_Vector *aEndPt, void *aClosure)
++lineto(const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *fti = (FT2PT1_info *)aClosure;
+ FT_UShort upm = fti->face->units_per_EM;
+@@ -279,7 +279,7 @@
+ }
+
+ static int
+-conicto(FT_Vector *aControlPt, FT_Vector *aEndPt, void *aClosure)
++conicto(const FT_Vector *aControlPt, const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *ftinfo = (FT2PT1_info *)aClosure;
+ FT_UShort upm = ftinfo->face->units_per_EM;
+@@ -311,7 +311,7 @@
+ }
+
+ static int
+-cubicto(FT_Vector *aControlPt1, FT_Vector *aControlPt2, FT_Vector *aEndPt,
++cubicto(const FT_Vector *aControlPt1, const FT_Vector *aControlPt2, const FT_Vector *aEndPt,
+ void *aClosure)
+ {
+ FT2PT1_info *ftinfo = (FT2PT1_info *)aClosure;
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 1d381a06fe88..e11caf5589e6 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.12 2006/03/09 00:45:43 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.15 2006/08/01 21:09:04 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
@@ -23,5 +23,7 @@ rm -f ${MOZDIR}/components.ini
rm -f ${MOZDIR}/defaults.ini
rm -f ${MOZDIR}/chrome/app-chrome.manifest
rm -rf ${MOZDIR}/updates
+find %%MOZDIR%%/plugins/ -depth 1 -type l -delete > /dev/null 2>&1
+find %%MOZDIR%%/extensions/ -depth 1 -type l -delete > /dev/null 2>&1
exit 0
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 13fe40dbee7a..bc083ae6da01 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-install.in,v 1.12 2006/03/09 00:45:43 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.15 2006/08/01 21:09:04 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
@@ -37,5 +37,7 @@ fi
if [ ! -d %%PREFIX%%/lib/browser_plugins ]; then
mkdir -p %%PREFIX%%/lib/browser_plugins
fi
+cp -R %%LOCALBASE%%/lib/npapi/symlinks/%%MOZILLA%%/ %%MOZDIR%%/plugins/ > /dev/null 2>&1
+cp -R %%LOCALBASE%%/lib/xpi/symlinks/%%MOZILLA%%/ %%MOZDIR%%/extensions/ > /dev/null 2>&1
exit 0