aboutsummaryrefslogtreecommitdiff
path: root/www/mozplugger
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-06-03 12:46:45 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-06-03 12:46:45 +0000
commit7ebcb96542c119c30f239acbfc15d083acdcf779 (patch)
tree7219c6b7a4b9e53851cd1d14736ac8b184351a58 /www/mozplugger
parent234dd642d770ebfa5f09a135a79dba010b1e3d05 (diff)
downloadports-7ebcb96542c119c30f239acbfc15d083acdcf779.tar.gz
ports-7ebcb96542c119c30f239acbfc15d083acdcf779.zip
Notes
Diffstat (limited to 'www/mozplugger')
-rw-r--r--www/mozplugger/Makefile35
-rw-r--r--www/mozplugger/distinfo2
-rw-r--r--www/mozplugger/files/patch-Makefile64
-rw-r--r--www/mozplugger/files/patch-mozplugger.c29
-rw-r--r--www/mozplugger/pkg-descr17
-rw-r--r--www/mozplugger/pkg-message11
-rw-r--r--www/mozplugger/pkg-plist5
7 files changed, 163 insertions, 0 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
new file mode 100644
index 000000000000..9cd7f4767a97
--- /dev/null
+++ b/www/mozplugger/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mozplugger
+# Date created: 2 June 2005
+# Whom: Loren M. Lang
+#
+# $FreeBSD$
+#
+
+PORTNAME= mozplugger
+PORTVERSION= 1.7.2
+CATEGORIES= www
+MASTER_SITES= http://download.mozdev.org/mozplugger/
+
+MAINTAINER= lorenl@alzatex.com
+COMMENT= Framework for loading web content in external viewers
+
+EXTRACT_DEPENDS=bzip2:${PORTSDIR}/archivers/bzip2
+
+MAN7= mozplugger.7
+
+USE_XLIB= yes
+USE_X_PREFIX= yes
+
+FETCH_CMD= /usr/bin/fetch -Rr
+
+ALL_TARGET= freebsd
+
+post-extract:
+ ${BZIP2_CMD} -d ${WRKSRC}/mozplugger.7.bz2
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/www/mozplugger/distinfo b/www/mozplugger/distinfo
new file mode 100644
index 000000000000..ad2b8302bf5b
--- /dev/null
+++ b/www/mozplugger/distinfo
@@ -0,0 +1,2 @@
+MD5 (mozplugger-1.7.2.tar.gz) = d9a4919caf36dbf1fb66b3a034d64cd2
+SIZE (mozplugger-1.7.2.tar.gz) = 54990
diff --git a/www/mozplugger/files/patch-Makefile b/www/mozplugger/files/patch-Makefile
new file mode 100644
index 000000000000..bf051582c556
--- /dev/null
+++ b/www/mozplugger/files/patch-Makefile
@@ -0,0 +1,64 @@
+--- Makefile.orig Sat Apr 16 12:24:24 2005
++++ Makefile Fri Jun 3 03:11:52 2005
+@@ -1,5 +1,5 @@
+ # Where is your Xwindows located?
+-X11=/usr/X11R6
++X11=${X11BASE}
+
+ #
+ # For building rpms
+@@ -7,14 +7,14 @@
+
+ #
+ # For installing
+-prefix=/usr
++prefix=${PREFIX}
+
+ #
+ #
+ RPMDIR=/usr/src/RPM
+
+ # Choose compiler
+-CC=gcc
++CC?=gcc
+ LD=gcc
+ BINFORMAT=bin
+
+@@ -60,7 +60,7 @@
+ ${MAKE} all CC=gcc XCFLAGS='-fPIC -aout' LD=gcc XLDFLAGS='-shared -aout'
+
+ freebsd:
+- ${MAKE} all CC=gcc XCFLAGS=-fPIC LD=gcc XLDFLAGS=-shared X11=/usr/X11R6/
++ ${MAKE} all CC=${CC} XCFLAGS=-fPIC LD=gcc XLDFLAGS=-shared X11=${X11BASE}
+
+ openbsd:
+ ${MAKE} all CC=gcc XCFLAGS=-fPIC LD=gcc XLDFLAGS=-shared X11=/usr/X11R6/
+@@ -91,7 +91,7 @@
+ mozplugger-common.c mozplugger.h README.in
+ BIN_FILES=mozplugger.so mozplugger-helper
+
+-DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -Wall #-DDEBUG #-D__amd64__
++DEFINES=$(STREAM) -DVERSION=\"$(VERSION)\" -DPREFIX=\"$(prefix)\" -Wall #-DDEBUG #-D__amd64__
+ RPM_OPT_FLAGS=-O2
+ COMMON_CFLAGS=$(RPM_OPT_FLAGS) -Inpapi/include -I$(X11)/include -DXP_UNIX $(DEFINES)
+ COMMON_LDFLAGS=
+@@ -156,14 +156,14 @@
+
+ install:
+ -@mkdir -p $(root)$(prefix)/bin
+- -@mkdir -p $(root)$(prefix)/lib/mozilla/plugins
++ -@mkdir -p $(root)$(prefix)/lib/browser_plugins
+ -@mkdir -p $(root)$(prefix)/share/man/man7
+- -@mkdir -p $(root)/etc
++ -@mkdir -p $(root)$(prefix)/etc
+ cp mozplugger-helper $(root)$(prefix)/bin/
+ cp mozplugger-controller $(root)$(prefix)/bin/
+- cp mozplugger.so $(root)$(prefix)/lib/mozilla/plugins/
+- cp mozpluggerrc $(root)/etc/
+- cp mozplugger.7.bz2 $(root)$(prefix)/share/man/man7/
++ cp mozplugger.so $(root)$(prefix)/lib/browser_plugins/
++ cp mozpluggerrc $(root)$(prefix)/etc/
++ cp mozplugger.7 $(root)$(prefix)/man/man7/
+
+ mozplugger.tar.gz: $(BASE_FILES) $(SOURCE_FILES)
+ @( DIR=`pwd`;\
diff --git a/www/mozplugger/files/patch-mozplugger.c b/www/mozplugger/files/patch-mozplugger.c
new file mode 100644
index 000000000000..bbf0cb982e77
--- /dev/null
+++ b/www/mozplugger/files/patch-mozplugger.c
@@ -0,0 +1,29 @@
+--- mozplugger.c.orig Sun Apr 17 05:19:59 2005
++++ mozplugger.c Fri Jun 3 20:55:32 2005
+@@ -568,6 +568,9 @@
+ if (cb(fname, data)) return 1;
+ }
+
++ snprintf(fname, sizeof(fname), PREFIX "/etc/%s", basename);
++ if (cb(fname, data)) return 1;
++
+ snprintf(fname, sizeof(fname), "/etc/%s", basename);
+ if (cb(fname, data)) return 1;
+
+@@ -1208,6 +1211,8 @@
+ *****************************************************************************/
+ NPError NPP_SetWindow(NPP instance, NPWindow* window)
+ {
++ XSetWindowAttributes attrib;
++
+ D("SetWindow\n");
+
+ if (!instance)
+@@ -1239,7 +1244,6 @@
+ D("Writing WIN 0x%x to fd %d\n", window->window, THIS->fd);
+ write(THIS->fd, (char *)window, sizeof(*window));
+
+- XSetWindowAttributes attrib;
+ attrib.override_redirect = True;
+ XChangeWindowAttributes(THIS->display, (Window)THIS->windata.window,
+ CWOverrideRedirect, &attrib);
diff --git a/www/mozplugger/pkg-descr b/www/mozplugger/pkg-descr
new file mode 100644
index 000000000000..73a5ab543980
--- /dev/null
+++ b/www/mozplugger/pkg-descr
@@ -0,0 +1,17 @@
+Moxplugger is a multimedia plugin for Unix Netscape 3.0 or later that
+handles Quicktime, MPEG, MP2, AVI, SGI-movie, Tiff, DL, IFF-anim,
+MIDI, Soundtracker, AU, WAV and Commodore 64 audio files. MPEG audio and
+video can be streamed.
+
+There is also support for viewing word documents and spreadsheets inline
+currently.
+
+Mozplugger is a very small plugin, because plugger uses external programs
+to show/play the different formats.
+
+This is based on Plugger 4.0 as released on Feburary 2003.
+
+WWW: http://mozplugger.mozdev.org/
+
+- Loren M. Lang
+lorenl@alzatex.com
diff --git a/www/mozplugger/pkg-message b/www/mozplugger/pkg-message
new file mode 100644
index 000000000000..797fd5dff844
--- /dev/null
+++ b/www/mozplugger/pkg-message
@@ -0,0 +1,11 @@
+This plugin needs external viewers before it can display any content.
+External viewers that are supported include:
+ Mplayer
+ Xine
+ Open Office
+ Timidity
+ XMMS
+ Adobe Acrobat Reader
+ Gnumeric
+ Abiword
+ and others...
diff --git a/www/mozplugger/pkg-plist b/www/mozplugger/pkg-plist
new file mode 100644
index 000000000000..a78302e1df15
--- /dev/null
+++ b/www/mozplugger/pkg-plist
@@ -0,0 +1,5 @@
+bin/mozplugger-helper
+bin/mozplugger-controller
+etc/mozpluggerrc
+lib/browser_plugins/mozplugger.so
+@unexec rmdir %D/lib/browser_plugins 2> /dev/null || true