aboutsummaryrefslogtreecommitdiff
path: root/www/mozplugger
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /www/mozplugger
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadports-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.gz
ports-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Notes
Diffstat (limited to 'www/mozplugger')
-rw-r--r--www/mozplugger/Makefile14
-rw-r--r--www/mozplugger/files/patch-Makefile4
-rw-r--r--www/mozplugger/pkg-plist4
3 files changed, 17 insertions, 5 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index 76c95cec4738..303b68255479 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mozplugger
PORTVERSION= 1.11.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://mozplugger.mozdev.org/files/
@@ -17,10 +18,21 @@ USE_XORG= x11 xt
MAN7= mozplugger.7
SUB_FILES= pkg-message
ALL_TARGET= freebsd
+MAKE_ENV= WEBPLUGINS_DIR="${WEBPLUGINS_DIR}"
+
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=mozplugger.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"/etc|"${PREFIX}/etc|g' \
+ ${WRKSRC}/mozplugger.c
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mozplugger/files/patch-Makefile b/www/mozplugger/files/patch-Makefile
index cc4895a37280..a7383100fb67 100644
--- a/www/mozplugger/files/patch-Makefile
+++ b/www/mozplugger/files/patch-Makefile
@@ -49,7 +49,7 @@
- -@mkdir -p $(root)$(prefix)/lib/mozilla/plugins
- -@mkdir -p $(root)$(prefix)/share/man/man7
- -@mkdir -p $(root)/etc
-+ -@mkdir -p $(root)$(prefix)/lib/browser_plugins
++ -@mkdir -p $(root)${WEBPLUGINS_DIR}
+ -@mkdir -p $(root)$(prefix)/man/man7
+ -@mkdir -p $(root)$(prefix)/etc
cp mozplugger-helper $(root)$(prefix)/bin/
@@ -58,7 +58,7 @@
- cp mozplugger.so $(root)$(prefix)/lib/mozilla/plugins/
- cp mozpluggerrc $(root)/etc/
- cp mozplugger.7 $(root)$(prefix)/share/man/man7/
-+ cp mozplugger.so $(root)$(prefix)/lib/browser_plugins/
++ cp mozplugger.so $(root)${WEBPLUGINS_DIR}/
+ cp mozpluggerrc $(root)$(prefix)/etc/
+ cp mozplugger.7 $(root)$(prefix)/man/man7/
diff --git a/www/mozplugger/pkg-plist b/www/mozplugger/pkg-plist
index 0199c83042a1..a82f152c6df4 100644
--- a/www/mozplugger/pkg-plist
+++ b/www/mozplugger/pkg-plist
@@ -2,5 +2,5 @@ bin/mozplugger-controller
bin/mozplugger-helper
bin/mozplugger-linker
etc/mozpluggerrc
-lib/browser_plugins/mozplugger.so
-@dirrmtry lib/browser_plugins
+%%WEBPLUGINS_DIR%%/mozplugger.so
+@dirrmtry %%WEBPLUGINS_DIR%%