aboutsummaryrefslogtreecommitdiff
path: root/www/mplayer-plugin/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-05 06:54:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-05 06:54:18 +0000
commit3501666ee3a2383e4a0e55e708a99bc1d50c27ca (patch)
tree0ed14fc68d7b5080bae1ef37f41ddcc29167524c /www/mplayer-plugin/Makefile
parent936b54f007e3eeba59ad72894b125ea4a21f3f3d (diff)
downloadports-3501666ee3a2383e4a0e55e708a99bc1d50c27ca.tar.gz
ports-3501666ee3a2383e4a0e55e708a99bc1d50c27ca.zip
Notes
Diffstat (limited to 'www/mplayer-plugin/Makefile')
-rw-r--r--www/mplayer-plugin/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 6850d594f73b..229bb687c1c6 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mplayerplug-in
-PORTVERSION= 0.91
-PORTREVISION= 1
+PORTVERSION= 0.95
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -23,7 +22,8 @@ USE_REINPLACE= yes
USE_GMAKE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/Source/mplayerplug-in.c
@@ -38,5 +38,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
${PREFIX}/etc/mplayerplug-in.conf ; \
fi
+ ${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
+ ${PREFIX}/etc/mplayerplug-in.types.dist
+ if [ ! -f ${PREFIX}/etc/mplayerplug-in.types ]; then \
+ ${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
+ ${PREFIX}/etc/mplayerplug-in.types ;\
+ fi
.include <bsd.port.mk>