aboutsummaryrefslogtreecommitdiff
path: root/www/mplayer-plugin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-06 07:33:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-06 07:33:20 +0000
commitd0faef72fddc217e76909ae036e7a7d2120f637c (patch)
tree2991a4e864de10e82639a37a072d500dde258746 /www/mplayer-plugin
parent59e00ec626ae75ad345e2a1638ec04368a495049 (diff)
downloadports-d0faef72fddc217e76909ae036e7a7d2120f637c.tar.gz
ports-d0faef72fddc217e76909ae036e7a7d2120f637c.zip
Notes
Diffstat (limited to 'www/mplayer-plugin')
-rw-r--r--www/mplayer-plugin/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index a10270f03211..415551c67689 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -14,9 +14,14 @@ MASTER_SITE_SUBDIR= mplayerplug-in
MAINTAINER= marcus@FreeBSD.org
COMMENT= A Mozilla plugin for the MPlayer media player
+.if defined(WITH_MOZILLA) && WITH_MOZILLA=="firefox"
+BUILD_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/mozilla-plugin.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/mozilla-plugin.pc:${PORTSDIR}/www/firefox
+.else
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
- ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
+.endif
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
HEADERS_SUFX=
@@ -44,6 +49,9 @@ HEADERS_SUFX= -devel-gtk1
CONFIGURE_ARGS+= --disable-gtk2 \
--enable-gtk1
.else
+.if ${WITH_MOZILLA}=="firefox"
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${X11BASE}/lib/firefox/lib/pkgconfig
+.else
HEADERS_SUFX= -gtk1
CONFIGURE_ARGS+= --disable-gtk2 \
--enable-gtk1
@@ -51,12 +59,14 @@ CONFIGURE_ARGS+= --disable-gtk2 \
.endif
.endif
.endif
+.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " By default this port uses www/mozilla for Gecko support, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
+ @${ECHO_MSG} " firefox "
@${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} " mozilla-gtk1 "
@${ECHO_MSG} " mozilla-devel-gtk1 "