aboutsummaryrefslogtreecommitdiff
path: root/www/mplayer-plugin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 08:21:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 08:21:09 +0000
commita092253b2bb3cdb39fe8e34e94de534303e78786 (patch)
tree263ee3add3356a858ce1852cc370aa07e4af4af1 /www/mplayer-plugin
parentbade40d1c8efd3bf27a2d82af840298e187130ca (diff)
downloadports-a092253b2bb3cdb39fe8e34e94de534303e78786.tar.gz
ports-a092253b2bb3cdb39fe8e34e94de534303e78786.zip
Notes
Diffstat (limited to 'www/mplayer-plugin')
-rw-r--r--www/mplayer-plugin/Makefile16
-rw-r--r--www/mplayer-plugin/distinfo4
-rw-r--r--www/mplayer-plugin/pkg-plist18
3 files changed, 29 insertions, 9 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 0a23f82964f4..06cbc3563cad 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mplayerplug-in
-PORTVERSION= 2.85
-PORTREVISION=
+PORTVERSION= 3.05
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -30,7 +29,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-PLUGINSFILES= mplayerplug-in.so mplayerplug-in.xpt
+PLUGINSFILES= mplayerplug-in.so mplayerplug-in.xpt mplayerplug-in-wmp.so \
+ mplayerplug-in-qt.so mplayerplug-in-rm.so mplayerplug-in-gmp.so
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -DBSD" \
@@ -82,21 +82,23 @@ post-patch:
${WRKSRC}/Source/plugin-setup.cpp
do-install:
- @${MKDIR} ${PREFIX}/lib/browser_plugins
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
.for moo in ${PLUGINSFILES}
- @${INSTALL_DATA} ${WRKSRC}/${moo} ${PREFIX}/lib/browser_plugins/
+ ${INSTALL_DATA} ${WRKSRC}/${moo} ${PREFIX}/lib/browser_plugins
.endfor
- @${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
+ ${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
${PREFIX}/etc/mplayerplug-in.conf.dist
if [ ! -f ${PREFIX}/etc/mplayerplug-in.conf ]; then \
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.conf \
${PREFIX}/etc/mplayerplug-in.conf ; \
fi
- @${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
+ ${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
${PREFIX}/etc/mplayerplug-in.types.dist
if [ ! -f ${PREFIX}/etc/mplayerplug-in.types ]; then \
${INSTALL_DATA} ${WRKSRC}/mplayerplug-in.types \
${PREFIX}/etc/mplayerplug-in.types ;\
fi
+ cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ Makefile ${MAKE_ARGS} install
.include <bsd.port.post.mk>
diff --git a/www/mplayer-plugin/distinfo b/www/mplayer-plugin/distinfo
index f2940e6daec1..f54308df2dc2 100644
--- a/www/mplayer-plugin/distinfo
+++ b/www/mplayer-plugin/distinfo
@@ -1,2 +1,2 @@
-MD5 (mplayerplug-in-2.85.tar.gz) = 57353e0f61640331972f860aa5fda3f1
-SIZE (mplayerplug-in-2.85.tar.gz) = 181541
+MD5 (mplayerplug-in-3.05.tar.gz) = 119c5634af875a712b27b90fdb1a3eb0
+SIZE (mplayerplug-in-3.05.tar.gz) = 190241
diff --git a/www/mplayer-plugin/pkg-plist b/www/mplayer-plugin/pkg-plist
index 8c151de6cbfe..257adaa3b34b 100644
--- a/www/mplayer-plugin/pkg-plist
+++ b/www/mplayer-plugin/pkg-plist
@@ -2,6 +2,24 @@
etc/mplayerplug-in.conf.dist
@unexec if cmp -s %D/etc/mplayerplug-in.types %D/etc/mplayerplug-in.types.dist; then rm -f %D/etc/mplayerplug-in.types; fi
etc/mplayerplug-in.types.dist
+lib/browser_plugins/mplayerplug-in-gmp.so
+lib/browser_plugins/mplayerplug-in-qt.so
+lib/browser_plugins/mplayerplug-in-rm.so
+lib/browser_plugins/mplayerplug-in-wmp.so
lib/browser_plugins/mplayerplug-in.so
lib/browser_plugins/mplayerplug-in.xpt
+share/locale/da/LC_MESSAGES/mplayerplug-in.mo
+share/locale/de/LC_MESSAGES/mplayerplug-in.mo
+share/locale/en_US/LC_MESSAGES/mplayerplug-in.mo
+share/locale/es/LC_MESSAGES/mplayerplug-in.mo
+share/locale/fr/LC_MESSAGES/mplayerplug-in.mo
+share/locale/it/LC_MESSAGES/mplayerplug-in.mo
+share/locale/ja/LC_MESSAGES/mplayerplug-in.mo
+share/locale/ko/LC_MESSAGES/mplayerplug-in.mo
+share/locale/nl/LC_MESSAGES/mplayerplug-in.mo
+share/locale/pl/LC_MESSAGES/mplayerplug-in.mo
+share/locale/pt_BR/LC_MESSAGES/mplayerplug-in.mo
+share/locale/ru/LC_MESSAGES/mplayerplug-in.mo
+@unexec rmdir %D/share/locale/en_US/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/en_US 2> /dev/null || true
@unexec rmdir %D/lib/browser_plugins 2>/dev/null || /usr/bin/true