aboutsummaryrefslogtreecommitdiff
path: root/www/mplayer-plugin
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-18 14:45:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-18 14:45:55 +0000
commitf5ebd6618c8594893177ce19c650b8edc06e6715 (patch)
tree045a33b4eb35c280fcc1f7596129bf4c2e3172e3 /www/mplayer-plugin
parenta2fe96c6e1f1cb699415e01f227fe430b0c84773 (diff)
downloadports-f5ebd6618c8594893177ce19c650b8edc06e6715.tar.gz
ports-f5ebd6618c8594893177ce19c650b8edc06e6715.zip
Notes
Diffstat (limited to 'www/mplayer-plugin')
-rw-r--r--www/mplayer-plugin/Makefile1
-rw-r--r--www/mplayer-plugin/files/patch-Source_plugin.cpp22
2 files changed, 23 insertions, 0 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 68d8a663157a..afb200191a47 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayerplug-in
PORTVERSION= 3.17
+PORTREVISION= 1
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
diff --git a/www/mplayer-plugin/files/patch-Source_plugin.cpp b/www/mplayer-plugin/files/patch-Source_plugin.cpp
new file mode 100644
index 000000000000..f929a3a6ed29
--- /dev/null
+++ b/www/mplayer-plugin/files/patch-Source_plugin.cpp
@@ -0,0 +1,22 @@
+===================================================================
+RCS file: /cvsroot/mplayerplug-in/mplayerplug-in/Source/plugin.cpp,v
+retrieving revision 1.263
+retrieving revision 1.264
+diff -u -r1.263 -r1.264
+--- Source/plugin.cpp 2005/12/12 14:05:08 1.263
++++ Source/plugin.cpp 2006/01/02 16:49:23 1.264
+@@ -388,9 +388,13 @@
+ paused = 0;
+ }
+ sendCommand(this, "quit\n");
+- pthread_mutex_lock(&read_mutex);
++#ifndef BSD
++ pthread_mutex_lock(&read_mutex);
++#endif
+ cancelled = 1;
++#ifndef BSD
+ pthread_mutex_unlock(&read_mutex);
++#endif
+ pthread_mutex_unlock(&control_mutex);
+ pthread_cancel(player_thread);
+ pthread_join(player_thread, NULL);