aboutsummaryrefslogtreecommitdiff
path: root/www/multisort
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-11 14:27:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-11 14:27:23 +0000
commit46b33e3dd696dc2cfbd62138dd40f4d4e1bf46f1 (patch)
tree9f66340a16d062243db5cbcb0d2c01e51d347e26 /www/multisort
parent5af96b5281465556e263541f5ecd078919fb7b94 (diff)
Notes
Diffstat (limited to 'www/multisort')
-rw-r--r--www/multisort/Makefile19
-rw-r--r--www/multisort/distinfo3
-rw-r--r--www/multisort/files/patch-Makefile18
-rw-r--r--www/multisort/pkg-descr10
4 files changed, 50 insertions, 0 deletions
diff --git a/www/multisort/Makefile b/www/multisort/Makefile
new file mode 100644
index 000000000000..a1a55ff550ba
--- /dev/null
+++ b/www/multisort/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: multisort
+# Date created: 06 Oct 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multisort
+PORTVERSION= 1.1
+CATEGORIES= www
+MASTER_SITES= http://www.xach.com/multisort/ \
+ http://mirror.mcx2.org/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A small program to take multiple httpd logfiles into one
+
+PLIST_FILES= bin/multisort
+
+.include <bsd.port.mk>
diff --git a/www/multisort/distinfo b/www/multisort/distinfo
new file mode 100644
index 000000000000..42fb9dc56606
--- /dev/null
+++ b/www/multisort/distinfo
@@ -0,0 +1,3 @@
+MD5 (multisort-1.1.tar.gz) = c47f7622773022119e1ea21d2b211bd3
+SHA256 (multisort-1.1.tar.gz) = 50cc0e84738f1c9b4b587e4d13564c233be20c693fd2154f2e8a293f3d5bc17d
+SIZE (multisort-1.1.tar.gz) = 3520
diff --git a/www/multisort/files/patch-Makefile b/www/multisort/files/patch-Makefile
new file mode 100644
index 000000000000..a5bc0682c10d
--- /dev/null
+++ b/www/multisort/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 1999-10-28 21:04:24.000000000 +0200
++++ Makefile 2008-10-07 18:48:41.000000000 +0200
+@@ -1,9 +1,10 @@
+-#
+-# $Id: Makefile,v 1.1 1999/01/14 19:05:35 xach Exp $
+-#
+-
++PREFIX?= /usr/local
+ CC = gcc
+ CFLAGS = -Wall -g -O2
+
+-multisort: multisort.c
++all:
+ $(CC) $(CFLAGS) -o multisort multisort.c
++
++install:
++ @mkdir -p ${DESTDIR}${PREFIX}/bin
++ install -m 755 multisort ${PREFIX}/bin
diff --git a/www/multisort/pkg-descr b/www/multisort/pkg-descr
new file mode 100644
index 000000000000..1c16ffc5350c
--- /dev/null
+++ b/www/multisort/pkg-descr
@@ -0,0 +1,10 @@
+`multisort' is a small program designed to take multiple httpd
+logfiles in the Common Log Format and merge them into a single log,
+sorted by date, sent to standard output.
+
+This is useful if you're running a single website on multiple hosts
+and using round-robin DNS to do load distribution. With multisort, you
+can take the various logfiles from each server and merge them into a
+single file for analysis.
+
+WWW: http://www.xach.com/multisort/