aboutsummaryrefslogtreecommitdiff
path: root/www/mythplugin-mythweb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-31 00:49:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-31 00:49:50 +0000
commit27805ba0b82386641ffd702d47e49b36941ec646 (patch)
tree4e9c9ce97de9513e593e9074ef8af37ff904fa51 /www/mythplugin-mythweb
parent5cd511feffd580125b5d91a4fb508190db56c9d1 (diff)
Notes
Diffstat (limited to 'www/mythplugin-mythweb')
-rw-r--r--www/mythplugin-mythweb/Makefile20
-rw-r--r--www/mythplugin-mythweb/files/pkg-message.in6
2 files changed, 23 insertions, 3 deletions
diff --git a/www/mythplugin-mythweb/Makefile b/www/mythplugin-mythweb/Makefile
index fabe22e32a2f..1049774cab69 100644
--- a/www/mythplugin-mythweb/Makefile
+++ b/www/mythplugin-mythweb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mythweb
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.oregonstate.edu/pub/mythtv/
@@ -19,18 +20,33 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD
NO_BUILD= yes
USE_BZIP2= yes
-USE_APACHE= 2.2+
USE_PHP= spl session mysql pcre posix json
SUB_FILES= pkg-message
+REINPLACE_ARGS= -i ""
+
+OPTIONS= APACHE "Enable Apache Support" on \
+ LIGHTTPD "Enable Lighttpd Support" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_APACHE)
+USE_APACHE= 2.2+
+.endif
+
+.if defined(WITH_LIGHTTPD)
+RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|/var/www/html|${WWWDIR}|' \
${WRKSRC}/mythweb/mythweb.conf.apache
+ @${REINPLACE_CMD} -e 's|/usr/bin/php-cgi|${LOCALBASE}/bin/php-cgi|' \
+ ${WRKSRC}/mythweb/mythweb.conf.lighttpd
do-install:
${MKDIR} ${WWWDIR}
${MKDIR} ${WWWDIR}/data
- (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.bak")
+ (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR})
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
${CHMOD} -R 775 ${WWWDIR}/data
diff --git a/www/mythplugin-mythweb/files/pkg-message.in b/www/mythplugin-mythweb/files/pkg-message.in
index f15c3f24b389..fe62f67af23b 100644
--- a/www/mythplugin-mythweb/files/pkg-message.in
+++ b/www/mythplugin-mythweb/files/pkg-message.in
@@ -4,4 +4,8 @@ mythweb has been installed into:
You need to configure mythweb now according to the instructions in
- %%WWWDIR%%/INSTALL \ No newline at end of file
+ %%WWWDIR%%/INSTALL
+
+For lighttpd you should have a look at the MythTV Wiki
+
+ http://www.mythtv.org/wiki/MythWeb_on_Lighttpd \ No newline at end of file