aboutsummaryrefslogtreecommitdiff
path: root/www/newsbeuter
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-08-05 12:24:47 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-08-05 12:24:47 +0000
commitad8f318f8ab4979cb18b3804b8a11639beb45f07 (patch)
tree0b752b046914a319f86c770459e70840719db991 /www/newsbeuter
parentd55cebffd4473b0fa27da145bf118994ad971b26 (diff)
downloadports-ad8f318f8ab4979cb18b3804b8a11639beb45f07.tar.gz
ports-ad8f318f8ab4979cb18b3804b8a11639beb45f07.zip
Notes
Diffstat (limited to 'www/newsbeuter')
-rw-r--r--www/newsbeuter/Makefile2
-rw-r--r--www/newsbeuter/files/patch-configcontainer.cpp10
2 files changed, 6 insertions, 6 deletions
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index c9ab081498e7..12289e76b2d8 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -6,7 +6,7 @@
PORTNAME= newsbeuter
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://synflood.at/newsbeuter/
diff --git a/www/newsbeuter/files/patch-configcontainer.cpp b/www/newsbeuter/files/patch-configcontainer.cpp
index bf2358fb0426..adc3cf35948f 100644
--- a/www/newsbeuter/files/patch-configcontainer.cpp
+++ b/www/newsbeuter/files/patch-configcontainer.cpp
@@ -1,7 +1,5 @@
-Index: src/configcontainer.cpp
-===================================================================
---- src/configcontainer.cpp (revision 935)
-+++ src/configcontainer.cpp (revision 937)
+--- src/configcontainer.cpp.orig 2007-06-06 15:23:55.000000000 +0200
++++ src/configcontainer.cpp 2007-08-05 14:19:34.000000000 +0200
@@ -85,43 +85,13 @@
return AHS_OK;
@@ -47,7 +45,7 @@ Index: src/configcontainer.cpp
default:
// should not happen
return AHS_INVALID_COMMAND;
-@@ -150,7 +120,35 @@
+@@ -150,7 +120,37 @@
}
std::string configcontainer::get_configvalue(const std::string& key) {
@@ -73,6 +71,8 @@ Index: src/configcontainer.cpp
+ filepath.append(homedir);
+ filepath.append(1,'/');
+ filepath.append(retval.substr(2,retval.length()-2));
++ } else {
++ filepath.append(retval);
+ }
+ } else {
+ filepath.append(retval);