aboutsummaryrefslogtreecommitdiff
path: root/www/newsbeuter
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-08-16 13:49:34 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-08-16 13:49:34 +0000
commite0b641dac7310ca02ffbdb99c6ec5152d48415e4 (patch)
treebb1ffbfe00b3b44ddc81d0475f3163ac5319b728 /www/newsbeuter
parentef8612393644246d6d144a64598f3c40e7a13790 (diff)
downloadports-e0b641dac7310ca02ffbdb99c6ec5152d48415e4.tar.gz
ports-e0b641dac7310ca02ffbdb99c6ec5152d48415e4.zip
Notes
Diffstat (limited to 'www/newsbeuter')
-rw-r--r--www/newsbeuter/Makefile3
-rw-r--r--www/newsbeuter/distinfo6
-rw-r--r--www/newsbeuter/files/patch-configcontainer.cpp86
3 files changed, 4 insertions, 91 deletions
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index 12289e76b2d8..c22203d1aad9 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= newsbeuter
-PORTVERSION= 0.5
-PORTREVISION= 3
+PORTVERSION= 0.6
CATEGORIES= www
MASTER_SITES= http://synflood.at/newsbeuter/
diff --git a/www/newsbeuter/distinfo b/www/newsbeuter/distinfo
index a2ab45ceb0aa..a4c996783f8b 100644
--- a/www/newsbeuter/distinfo
+++ b/www/newsbeuter/distinfo
@@ -1,3 +1,3 @@
-MD5 (newsbeuter-0.5.tar.gz) = 3e35d5475c6dc23f7a2aa7f056d97e43
-SHA256 (newsbeuter-0.5.tar.gz) = 250fa300d21e20f0bad8beccdd66cb9af2353c24eba757f7db6c8cf9adc83771
-SIZE (newsbeuter-0.5.tar.gz) = 119819
+MD5 (newsbeuter-0.6.tar.gz) = bdac313ecd68230be9aa0a4f61dd14a9
+SHA256 (newsbeuter-0.6.tar.gz) = a0c8c47dd53c50a20cd6ec3ff9a5f49fa944e4c9d380c0954a06213e7a1278de
+SIZE (newsbeuter-0.6.tar.gz) = 128889
diff --git a/www/newsbeuter/files/patch-configcontainer.cpp b/www/newsbeuter/files/patch-configcontainer.cpp
deleted file mode 100644
index adc3cf35948f..000000000000
--- a/www/newsbeuter/files/patch-configcontainer.cpp
+++ /dev/null
@@ -1,86 +0,0 @@
---- src/configcontainer.cpp.orig 2007-06-06 15:23:55.000000000 +0200
-+++ src/configcontainer.cpp 2007-08-05 14:19:34.000000000 +0200
-@@ -85,43 +85,13 @@
- return AHS_OK;
-
- case configdata::STR:
-+ case configdata::PATH:
- if (params.size() < 1) {
- return AHS_TOO_FEW_PARAMS;
- }
- cfgdata.value = params[0];
- return AHS_OK;
-
-- case configdata::PATH: {
-- if (params.size() < 1) {
-- return AHS_TOO_FEW_PARAMS;
-- }
--
-- // a path config option is a bit more difficult to handle, because we need to replace
-- // a possible "~/" at the beginning of the string with the user's home directory.
--
-- const char * homedir;
-- std::string filepath;
--
-- if (!(homedir = ::getenv("HOME"))) {
-- struct passwd * spw = ::getpwuid(::getuid());
-- if (spw) {
-- homedir = spw->pw_dir;
-- } else {
-- homedir = "";
-- }
-- }
--
-- if (strcmp(homedir,"")!=0 && params[0].substr(0,2) == "~/") {
-- filepath.append(homedir);
-- filepath.append(1,'/');
-- filepath.append(params[0].substr(2,params[0].length()-2));
-- } else {
-- filepath.append(params[0]);
-- }
--
-- cfgdata.value = filepath;
-- return AHS_OK;
-- }
- default:
- // should not happen
- return AHS_INVALID_COMMAND;
-@@ -150,7 +120,37 @@
- }
-
- std::string configcontainer::get_configvalue(const std::string& key) {
-- return config_data[key].value;
-+ std::string retval = config_data[key].value;
-+ if (config_data[key].type == configdata::PATH) {
-+ const char * homedir;
-+ std::string filepath;
-+
-+ if (!(homedir = ::getenv("HOME"))) {
-+ struct passwd * spw = ::getpwuid(::getuid());
-+ if (spw) {
-+ homedir = spw->pw_dir;
-+ } else {
-+ homedir = "";
-+ }
-+ }
-+
-+ if (strcmp(homedir,"")!=0) {
-+ if (retval == "~") {
-+ filepath.append(homedir);
-+ } else if (retval.substr(0,2) == "~/") {
-+ filepath.append(homedir);
-+ filepath.append(1,'/');
-+ filepath.append(retval.substr(2,retval.length()-2));
-+ } else {
-+ filepath.append(retval);
-+ }
-+ } else {
-+ filepath.append(retval);
-+ }
-+ retval = filepath;
-+ }
-+
-+ return retval;
- }
-
- int configcontainer::get_configvalue_as_int(const std::string& key) {