aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-11-24 18:29:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-11-24 18:29:40 +0000
commitdd0c16807ce05df8c31200f54550c04babe6e1fd (patch)
tree757558401bc8bc15636d250cf2093d359649491d /www/nghttp2
parentc3d466c7148be5332bbe55732d2c0a4a5f72775d (diff)
downloadports-dd0c16807ce05df8c31200f54550c04babe6e1fd.tar.gz
ports-dd0c16807ce05df8c31200f54550c04babe6e1fd.zip
Notes
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile13
-rw-r--r--www/nghttp2/distinfo4
-rw-r--r--www/nghttp2/pkg-descr2
-rw-r--r--www/nghttp2/pkg-plist7
4 files changed, 18 insertions, 8 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index ecd3e9a329a6..58dccac59c84 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.6
CATEGORIES= www net
MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/ \
LOCAL/sunpoet
@@ -18,7 +18,8 @@ LIB_DEPENDS= libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
libspdylay.so:${PORTSDIR}/www/spdylay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= HPACK
+OPTIONS_DEFINE= ASIO HPACK
+OPTIONS_DEFAULT=HPACK
OPTIONS_SUB= yes
CONFIGURE_ARGS= --disable-python-bindings \
@@ -39,8 +40,12 @@ USES= compiler:c++11-lang libtool pathfix pkgconfig tar:xz
PORTDOCS= *
-HPACK_CONFIGURE_OFF= --disable-hpack-tools
-HPACK_CONFIGURE_ON= --enable-hpack-tools
+ASIO_BUILD_DEPENDS= boost-libs>=1.54.0:${PORTSDIR}/devel/boost-libs
+ASIO_CONFIGURE_OFF= --with-boost=no
+ASIO_CONFIGURE_ON= --enable-asio-lib --with-boost=${LOCALBASE} --with-boost-asio --with-boost-system --with-boost-thread
+ASIO_LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+ASIO_RUN_DEPENDS= boost-libs>=1.54.0:${PORTSDIR}/devel/boost-libs
+HPACK_CONFIGURE_ENABLE= hpack-tools
HPACK_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
.include <bsd.port.pre.mk>
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index a146508bcd6c..25d9e024ec72 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nghttp2-0.6.2.tar.xz) = b03a9a98dce841df0afa625f63f87791dc9f9b665663b3dbe3d67aa83b272a90
-SIZE (nghttp2-0.6.2.tar.xz) = 793320
+SHA256 (nghttp2-0.6.6.tar.xz) = 3636ead6820e153990a61308d1bdbdb970a0980dd109fe73a710fbabcc0015b0
+SIZE (nghttp2-0.6.6.tar.xz) = 799492
diff --git a/www/nghttp2/pkg-descr b/www/nghttp2/pkg-descr
index f50bb283892a..0f125f395e4d 100644
--- a/www/nghttp2/pkg-descr
+++ b/www/nghttp2/pkg-descr
@@ -3,4 +3,4 @@ nghttp2 - HTTP/2.0 C Library
This is an experimental implementation of Hypertext Transfer Protocol version
2.0.
-WWW: http://tatsuhiro-t.github.io/nghttp2/
+WWW: https://nghttp2.org/
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 55b80ee0df36..9f4e450bb56d 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -10,8 +10,13 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.5
-lib/libnghttp2.so.5.1.0
+lib/libnghttp2.so.5.2.1
+%%ASIO%%lib/libnghttp2_asio.a
+%%ASIO%%lib/libnghttp2_asio.so
+%%ASIO%%lib/libnghttp2_asio.so.0
+%%ASIO%%lib/libnghttp2_asio.so.0.0.0
libdata/pkgconfig/libnghttp2.pc
+%%ASIO%%libdata/pkgconfig/libnghttp2_asio.pc
man/man1/h2load.1.gz
man/man1/nghttp.1.gz
man/man1/nghttpd.1.gz