aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-02-15 14:24:51 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-02-15 14:24:51 +0000
commitb2afa563c55bbab9fde0d13f02313925c4bccbe7 (patch)
tree61e763b6610f8f87b425f71282346a2d8f57f8df /www/nghttp2
parent1f0ef506ecab5ff5b6fd6b9ccc67c299a0739fda (diff)
downloadports-b2afa563c55bbab9fde0d13f02313925c4bccbe7.tar.gz
ports-b2afa563c55bbab9fde0d13f02313925c4bccbe7.zip
Notes
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile15
-rw-r--r--www/nghttp2/distinfo4
-rw-r--r--www/nghttp2/files/patch-configure.ac35
-rw-r--r--www/nghttp2/pkg-plist2
4 files changed, 45 insertions, 11 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 8e728ff11333..d4b2586dc1e6 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.1
+DISTVERSIONPREFIX= v
CATEGORIES= www net
-MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
@@ -19,12 +18,14 @@ BUILD_DEPENDS= libev>=4.15:${PORTSDIR}/devel/libev \
LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
libevent_openssl.so:${PORTSDIR}/devel/libevent2 \
libspdylay.so:${PORTSDIR}/www/spdylay
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= ASIO DOCS HPACK
OPTIONS_DEFAULT=HPACK
OPTIONS_SUB= yes
+USE_GITHUB= yes
+GH_ACCOUNT= tatsuhiro-t
+
CONFIGURE_ARGS= --disable-python-bindings \
--enable-app \
--enable-examples \
@@ -35,11 +36,12 @@ CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
ZLIB_LIBS="-L${LIBDIR} -lz"
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+PATHFIX_MAKEFILEIN= Makefile.am
USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= compiler:c++11-lib gmake libtool localbase pathfix pkgconfig tar:xz
+USES= autoreconf compiler:c++11-lib gmake libtool localbase pathfix pkgconfig
PORTDATA= fetch-ocsp-response
PORTDOCS= *
@@ -62,7 +64,4 @@ CPPFLAGS+= -D_GLIBCXX_USE_C99
CONFIGURE_ARGS+=--with-jemalloc
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/JEMALLOC_LIBS/ s|-ljemalloc||' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 826e6be96e24..b700f153d2f4 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nghttp2-1.6.0.tar.xz) = cc569501d243c934ea980a1f68fadb8ccc4f133ae8a5b15dcd29f0de76f9bac3
-SIZE (nghttp2-1.6.0.tar.xz) = 1399524
+SHA256 (tatsuhiro-t-nghttp2-v1.7.1_GH0.tar.gz) = 3f939b1507b4b9b94d8c1f873b41945d0c7bcf6a21c313124526201dc6e11c3c
+SIZE (tatsuhiro-t-nghttp2-v1.7.1_GH0.tar.gz) = 1561854
diff --git a/www/nghttp2/files/patch-configure.ac b/www/nghttp2/files/patch-configure.ac
new file mode 100644
index 000000000000..94e17924b1d2
--- /dev/null
+++ b/www/nghttp2/files/patch-configure.ac
@@ -0,0 +1,35 @@
+From e4b2847d3135a024c740d25f9e11da7ff0bf0fd6 Mon Sep 17 00:00:00 2001
+From: Bernard Spil <Sp1l@users.noreply.github.com>
+Date: Sat, 6 Feb 2016 14:36:27 +0100
+Subject: [PATCH] Don't check for dlopen/libdl on *BSD
+
+This makes linking fail on -ldl as there is no libdl on in /usr/lib or /usr/local/lib on *BSD
+Tested (and part of the proposed nghttp2 1.7.0) on [https://reviews.freebsd.org/D5218|FreeBSD]
+---
+ configure.ac | 13 ++++++++++---
+ 1 file changed, 10 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 09a2538..4a4defe 100644
+--- configure.ac.orig
++++ configure.ac
+@@ -256,9 +256,16 @@ if test "x${have_zlib}" = "xno"; then
+ fi
+
+ # dl: openssl requires libdl when it is statically linked.
+-LIBS_OLD=$LIBS
+-AC_SEARCH_LIBS([dlopen], [dl], [APPLDFLAGS="-ldl $APPLDFLAGS"], [], [])
+-LIBS=$LIBS_OLD
++case "${host_os}" in
++ *bsd*)
++ # dlopen is in libc on *BSD
++ ;;
++ *)
++ save_LIBS=$LIBS
++ AC_SEARCH_LIBS([dlopen], [dl], [APPLDFLAGS="-ldl $APPLDFLAGS"], [], [])
++ LIBS=$save_LIBS
++ ;;
++esac
+
+ # cunit
+ PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index 1f92ee55cf6d..5e45b564e2f7 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -12,7 +12,7 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.4.0
+lib/libnghttp2.so.14.4.1
%%ASIO%%lib/libnghttp2_asio.a
%%ASIO%%lib/libnghttp2_asio.so
%%ASIO%%lib/libnghttp2_asio.so.1