aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-03-02 13:06:51 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-03-02 13:06:51 +0000
commit567b2d8e7f1f0d904578b1cf815b39e62709f477 (patch)
tree7e707076297b60633789b9b59ac39eec46c2dca7 /www/nginx-devel/Makefile
parent585cf1f7fa05b396f25e246251b34141fcedb7ef (diff)
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 6f8300269adb..edb703371efa 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.38
+PORTVERSION= 0.7.39
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -18,6 +18,7 @@ MAINTAINER= osa@FreeBSD.org
COMMENT= Robust and small WWW server
OPTIONS= DEBUG "Enable nginx debugging" off \
+ IPV6 "Enable IPv6" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
HTTP_MODULE "Enable HTTP module" on \
HTTP_ACCESSKEY_MODULE "Enable http_accesskey module" off \
@@ -80,6 +81,11 @@ CONFIGURE_ARGS+=--with-debug
STRIP= #do not strip if nginx with debug information
.endif
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+=--with-ipv6
+CATEGORIES+= ipv6
+.endif
+
.if defined(WITH_GOOGLE_PERFTOOLS)
LIB_DEPENDS+= profiler.0:${PORTSDIR}/devel/google-perftools
CONFIGURE_ARGS+=--with-google_perftools_module