aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-02-10 19:30:19 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-02-10 19:30:19 +0000
commit5c4caee0d9f2342dabab5d93c1304c07d4b64662 (patch)
treec3d30d5a19e6e7c3081b3666416034392bdf1065 /www/nginx-devel/Makefile
parentaaf4bee536aac1de6e4a7e6b9961d1ee22c12ed3 (diff)
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 315126ee0fc0..8aff42cd532e 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -37,6 +37,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_UPLOAD_MODULE "Enable upload module" off \
HTTP_UPSTREAM_KEEPALIVE "Enable upstream keepalive module" off \
HTTP_XSLT_MODULE "Enable http_xslt module" off \
+ HTTP_ZIP_MODULE "Enable http_zip module" off \
MAIL_MODULE "Enable IMAP4/POP3/SMTP proxy module" off \
MAIL_IMAP_MODULE "Enable IMAP4 proxy module" off \
MAIL_POP3_MODULE "Enable POP3 proxy module" off \
@@ -175,6 +176,14 @@ USE_GNOME= libxml2 libxslt
CONFIGURE_ARGS+=--with-http_xslt_module
.endif
+.if defined(WITH_HTTP_ZIP_MODULE)
+NGINX_ZIP_MODULE_VERSION= 1.1.4
+MASTER_SITES+= ${MASTER_SITE_LOCAL}:zip
+MASTER_SITE_SUBDIR= osa/:zip
+DISTFILES+= nginx_mod_zip-${NGINX_ZIP_MODULE_VERSION}.tar.gz:zip
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_MODULE_VERSION}
+.endif
+
.if defined(WITHOUT_HTTP_REWRITE_MODULE) || defined(WITHOUT_PCRE)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nopcre
CONFIGURE_ARGS+=--without-http_rewrite_module \