aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2005-06-24 09:19:25 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2005-06-24 09:19:25 +0000
commit562d23f5c0436ad641b61530f824cac066822caa (patch)
tree1c33452cefcdb9499f95d8ae707e7450c2def06a /www/nginx-devel/Makefile
parent77fccdbd9d794cbfb8f28849408f84a5b20dd304 (diff)
downloadports-562d23f5c0436ad641b61530f824cac066822caa.tar.gz
ports-562d23f5c0436ad641b61530f824cac066822caa.zip
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f5470fdb7f28..345f71a812a2 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.1.36
+PORTVERSION= 0.1.37
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
@@ -36,13 +36,17 @@ CONFIGURE_ARGS+=--prefix=${PREFIX}/etc/nginx \
--with-http_stub_status_module \
--user=${WWWOWN} --group=${WWWGRP}
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--with-debug
+.endif
+
.if defined(WITH_OPENSSL_MODULE)
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-http_ssl_module
.endif
.if defined(WITHOUT_HTTP_REWRITE_MODULE) || defined(WITHOUT_PCRE)
-PKGNAMESUFFIX= -nopcre
+PKGNAMESUFFIX+= -nopcre
CONFIGURE_ARGS+=--without-http_rewrite_module \
--without-pcre
.else
@@ -50,15 +54,15 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.endif
.if defined(WITHOUT_WWW)
-PLIST_SUB+= WWWDATA="@comment "
+PLIST_SUB+= WWWDATA="@comment "
.else
-PLIST_SUB+= WWWDATA=""
+PLIST_SUB+= WWWDATA=""
.endif
.if defined(STOP_BEFORE_REMOVE)
PLIST_SUB+= STOP_BEFORE_REMOVE=""
.else
-PLIST_SUB+= STOP_BEFORE_REMOVE="@comment "
+PLIST_SUB+= STOP_BEFORE_REMOVE="@comment "
.endif
.if defined(START_AFTER_INSTALL)