aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2013-06-04 06:58:09 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2013-06-04 06:58:09 +0000
commitbb3008040a0f72d203677f6c9e14d1cd0cd0cba2 (patch)
tree26f25193b9a32798030731d8c5d46917b3e6a6cb /www/nginx-devel/Makefile
parentd146f4bee2128ba5976f553111f20a9ee62d09fa (diff)
downloadports-bb3008040a0f72d203677f6c9e14d1cd0cd0cba2.tar.gz
ports-bb3008040a0f72d203677f6c9e14d1cd0cd0cba2.zip
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 3912eacc5b0c..00dd1519edcd 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -82,6 +82,7 @@ OPTIONS_DEFINE= \
LET \
LUA \
MEMC \
+ MODSECURITY \
NAXSI \
PASSENGER \
POSTGRES \
@@ -170,6 +171,7 @@ ICONV_DESC= 3rd party iconv module
LET_DESC= 3rd party let module
LUA_DESC= 3rd party lua module
MEMC_DESC= 3rd party memc (memcached) module
+MODSECURITY_DESC= 3rd party mod_security module
NAXSI_DESC= 3rd party naxsi module
PASSENGER_DESC= 3rd party passenger module
POSTGRES_DESC= 3rd party postgresql module
@@ -626,6 +628,18 @@ DISTFILES+= agentzh-memc-nginx-module-v${NGINX_MEMC_VERSION}-${GIT_MEMC_VERSION}
CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-memc-nginx-module-${GIT_MEMC_VERSION:S/^0-g//}
.endif
+.if ${PORT_OPTIONS:MMODSECURITY}
+NGINX_MODSECURITY_VERSION= 2.7.4
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
+ apr-1:${PORTSDIR}/devel/apr1
+USE_APACHE= 22+
+USE_GNOME= libxml2
+MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION}/:modsecurity
+DISTFILES+= modsecurity-apache_${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nginx-modsecurity-config
+.endif
+
.if ${PORT_OPTIONS:MNAXSI}
NGINX_NAXSI_VERSION= 0.50
MASTER_SITES+= http://naxsi.googlecode.com/files/:naxsi
@@ -956,6 +970,18 @@ post-patch:
's!%%PREFIX%%!${LOCALBASE}!g' \
${WRKDIR}/calio-iconv-nginx-module-${GIT_ICONV_VERSION:S/^0-g//}/config
.endif
+.if ${PORT_OPTIONS:MMODSECURITY}
+ @${REINPLACE_CMD} \
+ 's!%%PREFIX%%!${LOCALBASE}!g' \
+ ${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION}/nginx/modsecurity/config
+.endif
+
+pre-configure:
+.if ${PORT_OPTIONS:MMODSECURITY}
+ ( cd ${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION} && \
+ CC="${CC}" ./${CONFIGURE_SCRIPT} --enable-standalone-module && \
+ ${MAKE} )
+.endif
do-build:
@cd ${WRKSRC} && ${MAKE}