aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-04-04 18:33:35 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-04-04 18:33:35 +0000
commit7b560971012d3cd75f47018bffba6781660071d5 (patch)
tree0b9d2e0972c822a4636ca1be87e2981fc475dc82 /www/nginx-devel/Makefile
parentb48961454d9380c03bcabe0326daf612b923ade0 (diff)
downloadports-7b560971012d3cd75f47018bffba6781660071d5.tar.gz
ports-7b560971012d3cd75f47018bffba6781660071d5.zip
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 94e319bcf46f..1ff6f599c345 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -63,6 +63,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_PUSH_MODULE "3rd party push module" off \
HTTP_REDIS_MODULE "3rd party http_redis module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
+ HTTP_SUBS_FILTER_MODULE "3rd party subs filter module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
HTTP_UPLOAD_PROGRESS "3rd party uploadprogress module" off \
HTTP_UPSTREAM_FAIR "3rd party upstream fair module" off \
@@ -310,6 +311,14 @@ DISTFILES+= ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}.tar.gz:response
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_SUBS_FILTER_MODULE)
+NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r44
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
+MASTER_SITE_SUBDIR+= osa/:subs_filter
+DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif