aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2008-08-05 08:11:06 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2008-08-05 08:11:06 +0000
commite9c5dcbe0d8a339a22119c93ce8176ad26a6a259 (patch)
tree953d0cf2d5774aa3c1ca33234e4f0b45e354f578 /www/nginx-devel/Makefile
parentd7ea2317937ac35a41ba026465744d9252530f0a (diff)
downloadports-e9c5dcbe0d8a339a22119c93ce8176ad26a6a259.tar.gz
ports-e9c5dcbe0d8a339a22119c93ce8176ad26a6a259.zip
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 259f135965a4..87895586f3c1 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.7
+PORTVERSION= 0.7.8
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -28,6 +28,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_SSL_MODULE "Enable http_ssl module" off \
HTTP_STATUS_MODULE "Enable http_stub_status module" on \
HTTP_SUB_MODULE "Enable http_sub module" off \
+ HTTP_XSLT_MODULE "Enable http_xslt module" off \
MAIL_MODULE "Enable IMAP4/POP3/SMTP proxy module" off \
MAIL_IMAP_MODULE "Enable IMAP4 proxy module" off \
MAIL_POP3_MODULE "Enable POP3 proxy module" off \
@@ -35,6 +36,8 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
MAIL_SSL_MODULE "Enable mail_ssl module" off \
WWW "Enable html sample files" on
+WANT_GNOME= yes
+
.include <bsd.port.pre.mk>
NGINX_VARDIR?= /var
@@ -114,6 +117,11 @@ CONFIGURE_ARGS+=--with-http_stub_status_module
CONFIGURE_ARGS+=--with-http_sub_module
.endif
+.if defined(WITH_HTTP_XSLT_MODULE)
+USE_GNOME= libxml2 libxslt
+CONFIGURE_ARGS+=--with-http_xslt_module
+.endif
+
.if defined(WITHOUT_HTTP_REWRITE_MODULE) || defined(WITHOUT_PCRE)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nopcre
CONFIGURE_ARGS+=--without-http_rewrite_module \