aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-06-18 16:12:38 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2012-06-18 16:12:38 +0000
commitb591b2a0487a9cb85a928f260d17bf28f82bfcdd (patch)
tree5d253af81ae89106e00db08134f372ec2faee5f7 /www/nginx-devel
parent0bca9d83609fb63a2e897a66768476f8e2e8d160 (diff)
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile6
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_subs_filter_module.c13
3 files changed, 5 insertions, 18 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 625f565f5430..18f26da13990 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -456,12 +456,12 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_VERSIO
.endif
.if ${PORT_OPTIONS:MHTTP_SUBS_FILTER}
-NGINX_HTTP_SUBS_FILTER_VERSION= 0.5.2.r53
+USE_HTTP_REWRITE= yes
+NGINX_HTTP_SUBS_FILTER_VERSION= 0.5.2.r59
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
MASTER_SITE_SUBDIR+= osa/:subs_filter
DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_subs_filter_module.c
.endif
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
@@ -611,7 +611,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/naxsi-${NGINX_NAXSI_VERSION}/naxsi_src
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-naxsi_src::naxsi_runtime.c
.endif
-.if ${PORT_OPTIONS:MHTTP_REWRITE}
+.if ${PORT_OPTIONS:MHTTP_REWRITE} || defined(USE_HTTP_REWRITE)
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--with-pcre
.else
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index d6ef272032d9..8108ecf73386 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -36,8 +36,8 @@ SHA256 (ngx_http_redis-0.3.6.tar.gz) = 9e5d8c0f1317a6910710c94d27f9aca4968c48ee1
SIZE (ngx_http_redis-0.3.6.tar.gz) = 12099
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
-SHA256 (ngx_http_subs_filter_module-0.5.2.r53.tar.gz) = 7db85255b0f8f3e7ea912a572c2a0a3e5a67f9771838cf1df072049fa9367000
-SIZE (ngx_http_subs_filter_module-0.5.2.r53.tar.gz) = 94682
+SHA256 (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 8fd9a185f092320a5290ad8b9f19bf0f7499167db275990c7f0228cd9aefb6fe
+SIZE (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 95092
SHA256 (nginx_upload_module-2.2.0.tar.gz) = b1c26abe0427180602e257627b4ed21848c93cc20cefc33af084983767d65805
SIZE (nginx_upload_module-2.2.0.tar.gz) = 25796
SHA256 (masterzen-nginx-upload-progress-module-v0.8.3-0-gc7c663f.tar.gz) = f391da7fd1a89bd65e852182b6cbc746289cd10c83b211be18e703ff3e3986ae
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_subs_filter_module.c b/www/nginx-devel/files/extra-patch-ngx_http_subs_filter_module.c
deleted file mode 100644
index 2739db922ca6..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_subs_filter_module.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ../ngx_http_subs_filter_module-0.5.2.r53/ngx_http_subs_filter_module.c.orig 2012-06-06 16:13:15.000000000 +0400
-+++ ../ngx_http_subs_filter_module-0.5.2.r53/ngx_http_subs_filter_module.c 2012-06-06 16:16:06.000000000 +0400
-@@ -1300,7 +1300,9 @@
-
- n = 0;
-
--#if defined(nginx_version) && nginx_version >= 1001012
-+#if defined(nginx_version) && (nginx_version >= 1003001)
-+ rc = pcre_fullinfo(re->code, NULL, PCRE_INFO_CAPTURECOUNT, &n);
-+#elif (nginx_version >= 1001012) && (nginx_version < 1003001)
- rc = pcre_fullinfo(re->pcre, NULL, PCRE_INFO_CAPTURECOUNT, &n);
- #else
- rc = pcre_fullinfo(re, NULL, PCRE_INFO_CAPTURECOUNT, &n);